User Guide    Caratteristiche avanzate    Creare un indice dei contenuti in PDF

Creare un indice dei contenuti in PDF

(Caratteristica avanzata di PDFpenPro)

Visualizza l'indice in PDFpenPro. (Barra laterale).

Creare un indice

  1. Apri l'indice nella barra laterale cliccando sul pulsante della Barra Laterale e scegliendo Indice dal menu. Oppure scegliete View > Table of Contents.
  2. Vai alla pagina che vuoi aggiungere all'Indice.
  3. Da quella pagina, puoi selezionare una specifica porzione di testo per essere il titolo di quella pagina nell'Indice. Seleziona ora quel testo.
  4. Clicca sul pulsante Cog action button nella parte inferiore della barra laterale e scegli Aggiungi voce. Trova le scorciatoie per questo in Edit > Table of Contents.
  5. "Pagina X" apparirà nell'indice. Puoi cliccare sulla voce per modificarla. Se hai selezionato del testo, quel testo apparirà ora come una delle intestazioni nell'Indice.

Combinare le tabelle dei contenuti
Combinare documenti con Tabelle dei contenuti unirà le voci, usando i nomi dei documenti come voci superiori. Combina i documenti trascinando un file nella barra laterale delle miniature di un documento aperto, trascinando le miniature da un documento all'altro, o usando lo script Combine PDFs, accessibile nel menu AppleScript AppleScript .

Accesso rapido alle modifiche
Clicca col tasto destro, o fai control-click, sulla Barra Laterale per accedere al menu contestuale che contiene le stesse opzioni del menu impostazioni . Le opzioni di modifica sono disponibili anche dalla Touch Bar sui Mac supportati.

Oltre a Add Entry, il menu Cog fornisce anche i seguenti mezzi per aggiungere nuove voci:

Aggiungi bambino
Aggiunge un figlio alla voce dell'indice attualmente selezionata. Combina Add Entry e Demote Entry in un'unica azione.

Aggiungi la zia
Aggiungere una zia, cioè un fratello del genitore della voce dell'Indice attualmente selezionata. Combina Aggiungi voce e Promuovi voce in un'unica azione.

Modifica delle voci dell'indice

Una volta aggiunti gli elementi all'Indice, ci sono diversi modi per modificare le voci: individua le scorciatoie da tastiera per la modifica in Modifica > Indice, oppure fai clic destro / Control-clic su una voce per accedere alle opzioni di modifica.

Shift-Click per selezionare una serie di voci di pagina per eseguire modifiche in batch sulle voci, come la retrocessione e la promozione.

Ecco alcune delle azioni di modifica che puoi fare su una voce:

Modificare il testo della voce
Fai doppio clic sulla voce per cambiare il testo.

Imposta destinazione
Riassegnare gli elementi dell'Indice dei Contenuti corrente invece di eliminare e creare nuovi elementi.

  1. Seleziona una voce.
  2. Seleziona il testo nel documento per specificare una nuova destinazione per la voce esistente.
  3. Scegli Imposta Destinazione nel menu Impostazioni .

Retrocedere una voce
Seleziona un elemento e scegli Retrocedi nel menu imopstazioni action button. La voce diventerà una sottovoce della voce di livello superiore più vicina nella lista.

Promuovere una voce
Seleziona un elemento e scegli Antecedi nel menu imopstazioni action button. La voce salirà di un livello rispetto alla sezione in cui si trova.

Cancellare una voce
Seleziona un elemento e scegli Rimuovi Elemento nel menu imopstazioni action button.

Copiare voci del sommario

Copia il testo di una voce, o copia l'intero Indice come elenco puntato.

  1. Clicca su una voce nella barra laterale . Premere Command+A per selezionare tutte le voci.
  2. Nel menu Modifica scegliete Copia come testo. Potete poi incollare le voci dove volete.