Guía Del Usuario    Características avanzadas    Creación de índices en PDF

Creación de índices en PDF

(Función avanzada de PDFpenPro)

Ver un índice de contenidos en PDFpenPro. (Barra lateral).

Creación de un índice de contenidos

  1. Para abrir el índice de contenidos en la barra lateral, haz clic en el botón de la barra lateral y elige Índice de contenidos en el menú. O selecciona Ver > Tabla de contenidos.
  2. Ve a la página que deseas añadir al índice.
  3. Desde esa página, puedes seleccionar una porción específica de texto para que sea el título de esa página en el Índice. Seleccionar ese texto ahora.
  4. Haz clic en el botón Cog action button en la parte inferior de la barra lateral y elige Añadir entrada. Localiza los atajos para esto en Edit > Table of Contents.
  5. "Página X" aparecerá en el índice. Puedes hacer clic en el elemento para editarlo. Si has seleccionado un texto, éste aparecerá como uno de los títulos del índice.

Combinación de tablas de contenido
La combinación de documentos con tablas de contenido fusionará las entradas, utilizando los nombres de los documentos como entradas superiores. Combina los documentos arrastrando un archivo a la barra lateral de miniaturas de un documento abierto, arrastrando las miniaturas de un documento a otro, o utilizando el script Combinar PDFs, accesible en el menú AppleScript AppleScript.

Acceso rápido a la edición
Haciendo clic con el botón derecho del ratón, o pulsando la tecla Control, en la barra lateral, se accede al menú contextual que contiene las mismas opciones que el menú Cog . Las opciones de edición también están disponibles desde la Touch Bar en los Macs compatibles.

Además de añadir una entrada, el menú Cog también ofrece los siguientes medios para añadir nuevas entradas:

Añadir hijo
Añade un hijo a la entrada del índice actualmente seleccionada. Combina la adición de entradas y la degradación de entradas en una sola acción.

Añadir tía
Añade una tía, es decir, un hermano del padre de la entrada del índice actualmente seleccionada. Combina Añadir Entrada y Promover Entrada en una sola acción.

Edición de las entradas del índice

Una vez que hayas añadido elementos al Índice, hay varias maneras de editar las entradas: localiza los atajos de teclado para la edición en Edición > Índice, o haz clic con el botón derecho del ratón / Control-clic en una entrada para acceder a las opciones de edición.

Haz clic en Mayúsculas para seleccionar un rango de entradas de la página para realizar ediciones por lotes en las entradas, como degradar y promover.

Estas son algunas de las acciones de edición que puedes realizar en una entrada:

Editar el texto de la entrada
Haz doble clic en la entrada para cambiar el texto.

Fijar el destino
Reasignar las entradas actuales del índice de contenidos en lugar de eliminar y crear entradas nuevas.

  1. Selecciona una entrada.
  2. Selecciona el texto en el documento para especificar un nuevo destino para la entrada existente.
  3. Selecciona Establecer destino en el menú Cog .

Desplazar una entrada
Selecciona una entrada y elige Degradar en el menú Cog action button. La entrada se convertirá en un subtítulo de la entrada superior más cercana en la lista.

Promover una entrada
Selecciona una entrada y elige Promover en el menú Cog action button. La entrada subirá un nivel desde la sección en la que se encuentra.

Borrar una entrada
Selecciona una entrada y elige Eliminar entrada en el menú Cog action button.

Copiar las entradas del índice

Copia el texto de una entrada o copia todo el índice como una lista con viñetas.

  1. Haz clic en una entrada de la barra lateral . Pulsa Comando+A para seleccionar todas las entradas.
  2. En el menú Editar selecciona Copiar como texto. A continuación, puedes pegar las entradas donde desees.