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About PDFpenPro
PDFpenPro Basics (features, installation, purchase & registration)

What's New In This Version?

Demo Version, Purchase/Registration

Getting Started: Guided Tour
View Options and Getting Around a PDF

Toolbar

Editing Bar

Font Bar

Sidebar

Inspector

Library

Preferences

Opening New and Existing PDF files

Searching Within a PDF

Redact or Replace Text from Keyword Search

Undo/Redo

Editing PDFs and Adding Content
Working With Text

Selecting Text

Correcting Text

Adding Text

Formatting Text

Markup: Highlighting, Underline, Strikethrough

Redacting Text

Images, Signatures, Objects and Imprints
Adding Images

Editing Images

Cropping Images

Adding Objects: Scribbles, Lines and Shapes

Arranging Items

Imprints

Watermarks

Signing Documents
Adding a Basic Signature

Using Interactive Signature Fields

Digital Signatures

Validation

Signing a PDF with a Digital Signature

Sign or Send with DocuSign® (PDFpenPro only)

Sign Documents with DocuSign

Send Documents for Signatures with DocuSign

Notes, Comments, Links, Bookmarks and Attachments
Adding Notes and Comments

Printing Notes and Comments

Adding Links

Bookmarks

Attachments

Extracting File Attachments

http://smilesoftware.com/


 

Adding File Attachments (PDFpenPro only)

Adding Audio annotations

Forms
Filling Out PDF Forms

Signing a Form

Scanning
Scanning a Document

OCR
Using OCR (Optical Character Recognition)

Batch OCR

Forcing OCR

Viewing the OCR Layer

Remove the OCR Layer

Dictionaries and OCR

Editing the OCR Layer (PDFpenPro Only)

Working With PDF Documents
Adding Pages

Deleting Pages

Reordering Pages

Extracting Pages

Combining PDFs

Selecting Part of a Page

Cropping Pages and Documents

Numbering Pages

Bates Numbering

Line Numbers

Headers and Footers

Reducing Document File Size

Printing

iCloud

AppleScript

PDFpenPro Advanced Features
Creating and Editing a Table of Contents

Convert HTML to PDF

Creating PDF Forms

PDF Applications and Submitting Forms

Portfolios

Saving and Exporting
Saving and Compressing File Size

Exporting in Microsoft® Word Format

Exporting to Microsoft® Excel, PowerPoint, and PDF/A Format (PDFpenPro Only)

Exporting in Various Formats

Exporting to Plain text or Formatted text

Export as TIFF, JPEG, PNG, Flattened PDF

Saving to Evernote

Sharing documents

Passwords, Permissions and Encryption

Getting Answers
Transitioning to PDFpenPro 12

PDFpenPro Support and Frequently Asked Questions [web]

PDFpenPro Video Tutorial [web]

Visit the PDFpenPro Website [web]

Free “Take Control of PDFpen” ebook [web]
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Help — Edit PDFs easily with PDFpenPro!
Add text, images and signatures. Combine, proof, and edit documents. Fix typos, resize images, fill out forms,
and redact sensitive information. Use OCR (Optical Character Recognition) to digitize scanned documents,
export to Microsoft® Word and password protect.
Create fillable, submittable forms and Tables of Contents. Send for signatures with DocuSign®. Convert HTML
to PDF and PDF to XLSX, PPTX and PDF/A with PDFpenPro!
Features of PDFpen and PDFpenPro:

Add text, images and signatures to PDF

Correct text in original PDF with editable text blocks

Fill out interactive PDF forms and sign them

Redact or erase text, including OCR text

Search and replace, search and redact, and search and highlight text

Export in Microsoft® Word format for more extensive editing, as well as TIFF, JPEG, PNG, and flat PDF

Scan directly from Image Capture or TWAIN scanners

Perform OCR (Optical Character Recognition) on scanned documents

View OCR layer for proofing OCR text from scanned pages, or remove OCR layer

Edit original images, including adjust resolution, color depth and contrast, skew, and size of an image or scanned document

Sign PDF forms via drawing, interactive signature fields, or AATL or self-signed certificates

Insert and remove pages; re-order pages in a PDF by drag & drop; combine PDFs maintaining Table of Contents entries

Move, resize, copy and delete images in original PDF

Save PDFs directly to Evernote

Preview and extract file attachments and annotations

Record and playback audio annotations

Copy and paste rich text; retain fonts and formatting when copying from PDFs, including columns

Context-sensitive popup-menus enable quick edits

Add notes and comments, print summary with or without the original text

Mark up documents with highlighting, underscoring and strikethrough

Save frequently-used images, signatures, objects and text in the Library and sync Library items with PDFpen for iPad & iPhone via

iCloud

Add page numbers, bookmarks, headers and footers, line numbers and watermarks

Apply stamps, such as Sign Here and Draft, via the Library

Print a list of all annotations along with the document

Password protect a document with up to 256-bit AES encryption

Automate PDF manipulations with AppleScript and JavaScript Automation

Available in English, Japanese, German, French, Italian, and Spanish

PDFpenPro only. Learn more about going Pro at Smilesoftware.com/PDFpenPro.

Export to Microsoft® Excel (.xlsx, .xls), Microsoft® PowerPoint (.pptx) and PDF Archive (PDF/A) formats (requires Internet

connection for .pptx and PDF/A, must be a licensed user)

Create cross-platform fillable PDF forms including interactive signature fields and email or web submission buttons

Create and edit Table of Contents

Convert websites into PDFs

Add and edit document permissions

Automatic form creation makes existing PDF forms fillable

Gather submitted form data via backend integration

Add and delete file attachments and annotations

Create Portfolio documents, combining related files together

Correct typos in OCR text layer

OCR horizontal Chinese, Japanese, and Korean

DocuSign® support

System Requirements
Purchasing
Upgrades
Installing
Help
Uninstall
Disclaimer
System Requirements
macOS 10.13 (High Sierra) or later.

Purchasing
PDFpen costs US $79.95. PDFpenPro costs US $129.95. Purchases can be made from:

The demo itself (recommended)

The Smile web store: PDFpen and PDFpenPro

The Mac App Store

http://smilesoftware.com/
http://smilesoftware.com/cgi-bin/redirect.pl?product=pdfpen-ios&cmd=itunes&version=3
https://smilesoftware.com/pdfpenpro
http://smilesoftware.com/cgi-bin/redirect.pl?product=pdfpen&cmd=webstore
http://smilesoftware.com/cgi-bin/redirect.pl?product=pdfpenpro&cmd=webstore


Upgrades
Upgrade pricing:

Upgrade from an earlier PDFpen to PDFpen 12: $35

Upgrade from an earlier PDFpenPro to PDFpenPro 12: $35

Upgrade from an earlier PDFpen to PDFpenPro 12: $50

When upgrading from PDFpen to PDFpenPro 12 use the “Upgrade to PDFpenPro…” menu item in the PDFpen menu of the application.

Upgrades can also be purchased at the Smile Store.

Free Upgrades are available if version 11 was purchased on or after January 1, 2020. Free upgrades are not available in the Mac App

Store version.

You can find the latest versions of PDFpen and PDFpenPro, and the latest technical support, at: https://smilesoftware.com/PDFpen

Updates within a version number are free to registered users. For example, registered users of PDFpen 12 .0 can get the PDFpen 12 .1

update for free. Smile reserves the right to change the update policy.

How Do I Install the Application?
Simply drag PDFpenPro from its disk image to your Applications folder, or wherever you prefer to put your applications. Then you may

eject, or unmount, the disk image. You'll see it in Finder under Devices.

Where Can I Get Help?
PDFpenPro ships with extensive online help. Select PDFpenPro Help (Help Viewer) from the Help menu to view the help with Apple's Help

Viewer application, or select PDFpenPro Help (Web Browser) to view the PDFpenPro help in your default web browser.

How Do I Uninstall the Application?
Drag the PDFpenPro application icon to the Trash.

For complete removal, also move to the Trash:

[Home] / Library / Containers / com.smileonmymac.PDFpenPro .

Disclaimer
This software is provided "as is" and any express or implied warranties, including, but not limited to, the implied warranties of

merchantibility and fitness for a particular purpose are disclaimed. In no event shall the copyright owner or contributors be liable for any

direct, indirect, incidental, special, exemplary, or consequential damages (including, but not limited to, procurement of substitute goods or

services; loss of use, data, or profits; or business interruption) however caused and on any theory of liability, whether in contract, strict

liability, or tort (including negligence or otherwise) arising in any way out of the use of this software, even if advised of the possibility of

such damage.

PDFpenPro is produced by:

SmileOnMyMac, LLC dba Smile

PMB 278

350 Bay Street, Suite 100,

San Francisco, CA 94133

We welcome your inquiries and feedback at support.

Acknowledgments

PDFpenPro includes objective-c-jwt-simple, which stipulates we include the following:

Copyright and Permission Notice

Copyright (c) 2015 Nathan Ducrey

Permission is hereby granted, free of charge, to any person obtaining a copy
of this software and associated documentation files (the "Software"), to deal
in the Software without restriction, including without limitation the rights
to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
copies of the Software, and to permit persons to whom the Software is
furnished to do so, subject to the following conditions:

The above copyright notice and this permission notice shall be included in all
copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
AUTHORS OR Copyright 2003-2020 SmileOnMyMac LLC, dba Smile HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
SOFTWARE.

--

PDFpenPro includes MGTemplateEngine code by Matt Gemmell

License Agreement for Source Code provided by Matt Gemmell

https://smilesoftware.com/PDFpen
https://smilesoftware.com/cgi-bin/redirect.pl?product=pdfpenpro&cmd=support


This software is supplied to you by Matt Gemmell in consideration of
your agreement to the following terms, and your use, installation,
modification or redistribution of this software constitutes acceptance
of these terms. If you do not agree with these terms, please do not use,
install, modify or redistribute this software.

In consideration of your agreement to abide by the following terms, and
subject to these terms, Matt Gemmell grants you a personal,
non-exclusive license, to use, reproduce, modify and redistribute the
software, with or without modifications, in source and/or binary forms;
provided that if you redistribute the software in its entirety and
without modifications, you must retain this notice and the following
text and disclaimers in all such redistributions of the software, and
that in all cases attribution of Matt Gemmell as the original author of
the source code shall be included in all such resulting software
products or distributions.
 Neither the name, trademarks, service marks
or logos of Matt Gemmell or Instinctive Code may be used to endorse or
promote products derived from the software without specific prior
written permission from Matt Gemmell. Except as expressly stated in this
notice, no other rights or licenses, express or implied, are granted by
Matt Gemmell herein, including but not limited to any patent rights that
may be infringed by your derivative works or by other works in which the
software may be incorporated.

The software is provided by Matt Gemmell on an "AS IS" basis. MATT
GEMMELL AND INSTINCTIVE CODE MAKE NO WARRANTIES, EXPRESS OR IMPLIED,
INCLUDING WITHOUT LIMITATION THE IMPLIED WARRANTIES OF NON-INFRINGEMENT,
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE, REGARDING THE
SOFTWARE OR ITS USE AND OPERATION ALONE OR IN COMBINATION WITH YOUR
PRODUCTS.

IN NO EVENT SHALL MATT GEMMELL OR INSTINCTIVE CODE BE LIABLE FOR ANY
SPECIAL, INDIRECT, INCIDENTAL OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF
USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) ARISING IN ANY WAY OUT
OF THE USE, REPRODUCTION, MODIFICATION AND/OR DISTRIBUTION OF THE
SOFTWARE, HOWEVER CAUSED AND WHETHER UNDER THEORY OF CONTRACT, TORT
(INCLUDING NEGLIGENCE), STRICT LIABILITY OR OTHERWISE, EVEN IF MATT
GEMMELL OR INSTINCTIVE CODE HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH
DAMAGE.

--

PDFpenPro includes libcurl, which stipulates we include the following:

Copyright and Permission Notice

Copyright (c) 1996 - 2002, Daniel Stenberg, daniel@haxx.se.

All rights reserved.

Permission to use, copy, modify, and distribute this software for any
purpose with or without fee is hereby granted, provided that the above
copyright notice and this permission notice appear in all copies.

The software is provided "as is", without warranty of any kind, express
or implied, including but not limited to the warranties of
merchantability, fitness for a particular purpose and noninfringement of
third party rights. In no event shall the authors or copyright holders
be liable for any claim, damages or other liability, whether in an
action of contract, tort or otherwise, arising from, out of or in
connection with the software or the use or other dealings in the
software.

Except as contained in this notice, the name of a copyright holder shall
not be used in advertising or otherwise to promote the sale, use or
other dealings in this Software without prior written authorization of
the copyright holder.

--

PDFpenPro includes PDF data structures, which are copyrighted by Adobe
Systems Incorporated. These structures are used by permission, as
outlined in section 1.4 of "PDF Reference (third edition)" by Adobe
Systems Incorporated (ISBN 0-201-75839-3).



--

PDFpenPro includes BDAlias, which stipulates we include the following:

Copyright © 2001-2002, bDistributed.com, Inc. All rights reserved.

Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are
met:

* Redistributions of source code must retain the above copyright
notice, this list of conditions and the following disclaimer.

* Redistributions in binary form must reproduce the above copyright
notice, this list of conditions and the following disclaimer in the
documentation and/or other materials provided with the distribution.

* Neither the name of bDistributed.com, Inc. nor the names of its
contributors may be used to endorse or promote products derived from
this software without specific prior written permission.

This software is provided by the copyright holders and contributors "as
is" and any express or implied warranties, including, but not limited
to, the implied warranties of merchantability and fitness for a
particular purpose are disclaimed. In no event shall the regents or
contributors be liable for any direct, indirect, incidental, special,
exemplary, or consequential damages (including, but not limited to,
procurement of substitute goods or services; loss of use, data, or
profits; or business interruption) however caused and on any theory of
liability, whether in contract, strict liability, or tort (including
negligence or otherwise) arising in any way out of the use of this
software, even if advised of the possibility of such damage.

--

PDFpenPro includes software by Dave Batton, which requires attribution
and is licensed as follows:

http://creativecommons.org/licenses/by/2.5/

--

PDFpenPro includes expat, which stipulates we include the following:

Copyright (c) 1998, 1999, 2000 Thai Open Source Software Center Ltd and
Clark Cooper Copyright (c) 2001, 2002 Expat maintainers.

Permission is hereby granted, free of charge, to any person obtaining a
copy of this software and associated documentation files (the
"Software"), to deal in the Software without restriction, including
without limitation the rights to use, copy, modify, merge, publish,
distribute, sublicense, and/or sell copies of the Software, and to
permit persons to whom the Software is furnished to do so, subject to
the following conditions:

The above copyright notice and this permission notice shall be included
in all copies or substantial portions of the Software.

The software is provided "as is", without warranty of any kind, express
or implied, including but not limited to the warranties of
merchantability, fitness for a particular purpose and noninfringement.
In no event shall the authors or copyright holders be liable for any
claim, damages or other liability, whether in an action of contract,
tort or otherwise, arising from, out of or in connection with the
software or the use or other dealings in the software.

--

PDFpenPro includes software by Apache Thrift Copyright 2006-2009 The
Apache Software Foundation, et al.

   Licensed under the Apache License, Version 2.0 (the "License"); you
   may not use this file except in compliance with the License. You may
   obtain a copy of the License at

       http://www.apache.org/licenses/LICENSE-2.0



   Unless required by applicable law or agreed to in writing, software
   distributed under the License is distributed on an "AS IS" BASIS,
   WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
   implied. See the License for the specific language governing
   permissions and limitations under the License.

--

PDFpenPro includes the Sparkle framework Copyright (c) 2006 Andy
Matuschak

Permission is hereby granted, free of charge, to any person obtaining a
copy of this software and associated documentation files (the
"Software"), to deal in the Software without restriction, including
without limitation the rights to use, copy, modify, merge, publish,
distribute, sublicense, and/or sell copies of the Software, and to
permit persons to whom the Software is furnished to do so, subject to
the following conditions:

The above copyright notice and this permission notice shall be included
in all copies or substantial portions of the Software.

The software is provided "as is", without warranty of any kind, express
or implied, including but not limited to the warranties of
merchantability, fitness for a particular purpose and noninfringement.
In no event shall the authors or copyright holders be liable for any
claim, damages or other liability, whether in an action of contract,
tort or otherwise, arising from, out of or in connection with the
software or the use or other dealings in the software.

--

PDFpenPro includes object code and links to the Nuance OmniPage
Capture SDK Copyright (c) 1995-2008, Nuance Communications, Inc.

The JPEG image read and write capability of the Nuance OmniPage Capture
SDK is based on the work of the Independent JPEG Group.

The Portable Network Graphics (PNG) image file read and write capability
of the Nuance OmniPage Capture SDK is based, in part, on the work of
Colosseum Builders, Inc.

The Portable Network Graphics (PNG) image file read and write capability
of the Nuance OmniPage Capture SDK is based, in part, on the PNG
Reference Library (libpng).

The Portable Network Graphics (PNG) image and the PDF file read and
write capability of the Nuance OmniPage Capture SDK is based, in part,
on the zlib Compression Library.

The PDF read capability of the Nuance OmniPage Capture SDK is based, in
part, on the work of the FreeType team.

The JPEG 2000 image read and write capability of the Nuance OmniPage
Capture SDK was developed using the Kakadu software.

The language dictionary support of the Nuance OmniPage Capture SDK is
partly from Proximity. The Proximity Dictionaries © 2000, all rights
reserved Proximity Technology, Inc.

This product includes software developed by the OpenSSL Project for use
in the OpenSSL Toolkit (http://www.openssl.org/).

This product includes cryptographic software written by Eric Young
(eay@cryptsoft.com).

This product includes software written by Tim Hudson
(tjh@cryptsoft.com).

XML reading is based partly on the Xerces and Xqilla libraries.

-- PDFpenPro includes FsprgEmbeddedStore Copyright (c) 2010
FastSpring, LLC

Permission is hereby granted, free of charge, to any person obtaining a



copy of this software and associated documentation files (the
"Software"), to deal in the Software without restriction, including
without limitation the rights to use, copy, modify, merge, publish,
distribute, sublicense, and/or sell copies of the Software, and to
permit persons to whom the Software is furnished to do so, subject to
the following conditions:

The above copyright notice and this permission notice shall be included
in all copies or substantial portions of the Software.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
IN NO EVENT SHALL THE AUTHORS OR Copyright 2003-2020 SmileOnMyMac LLC, dba Smile HOLDERS BE LIABLE FOR ANY
CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT,
TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE
SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.

--

PDFpenPro includes BlocksKit Copyright (c) 2011-2012 Zachary
Waldowski, Alexsander Akers, and the BlocksKit Contributors.

Permission is hereby granted, free of charge, to any person obtaining a
copy of this software and associated documentation files (the
"Software"), to deal in the Software without restriction, including
without limitation the rights to use, copy, modify, merge, publish,
distribute, sublicense, and/or sell copies of the Software, and to
permit persons to whom the Software is furnished to do so, subject to
the following conditions:

The above copyright notice and this permission notice shall be included
in all copies or substantial portions of the Software.

The software is provided "as is", without warranty of any kind, express
or implied, including but not limited to the warranties of
merchantability, fitness for a particular purpose and noninfringement.
In no event shall the authors or copyright holders be liable for any
claim, damages or other liability, whether in an action of contract,
tort or otherwise, arising from, out of or in connection with the
software or the use or other dealings in the software.

All of the code included in BlocksKit is licensed either under BSD or
MIT, or is otherwise in the public domain. You can use BlocksKit in any
project, public or private, with or without attribution.

--

PDFpenPro includes NSAlert-SynchronousSheet Copyright (c) 2011,
Incredible Bee Ltd. All rights reserved.

Redistribution and use in source and binary forms, with or without
modification, are permitted provided that the following conditions are
met:

- Redistributions of source code must retain the above copyright notice,
this list of conditions and the following disclaimer. - Redistributions
in binary form must reproduce the above copyright notice, this list of
conditions and the following disclaimer in the documentation and/or
other materials provided with the distribution. - Neither the name of
the Incredible Bee Ltd. nor the names of its contributors may be used to
endorse or promote products derived from this software without specific
prior written permission.

THIS SOFTWARE IS PROVIDED BY THE Copyright 2003-2020 SmileOnMyMac LLC, dba Smile HOLDERS AND CONTRIBUTORS "AS
IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED
TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL INCREDIBLE BEE LTD.
BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF
THE POSSIBILITY OF SUCH DAMAGE.
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Help: What's New In PDFpenPro?
We've been hard at work on PDFpenPro, continually adding improvements. We hope you enjoy

the results!

Detailed release notes are also available.

PDFpenPro 12.0 2020-04-28

Optimize PDFs for smaller files sizes

Customize image quality/settings

Delete 3rd party metadata

Advanced PDF compression (integrated)

MRC

CCITT

Post OCR

Magnifier window

Callout tool

Customized paper styles

DocuSign® support (PDFpenPro only)

New welcome experience

PDFpenPro 11.2.2 2020-03-31

Removes items which provoke contacts access request

Improves appearance of major upgrade overlay

PDFpenPro 11.2.1 2020-01-09

Fixes issue where signatures turn black when made transparent

Removes text-only option in toolbar

Other fixes and improvements

PDFpenPro 11.2 2019-11-05

Adds ability to edit content in table cells

Other fixes and improvements

PDFpenPro 11.1.2 2019-10-17

Resolves Catalina crash related to cursor rectangles

Resolves Catalina crash related to notes

PDFpenPro 11.1.1 2019-10-03

Resolves registration issue when upgrading to Catalina

PDFpenPro 11.1 2019-07-09

Improves ability to select and copy column and table data

Adds automatic page rotation option for scans:

Rotate and deskew scanned pages independently of OCR

Rotate and deskew scanned pages when performing OCR

Other fixes and improvements

PDFpenPro 11.0.3 2019-06-18

Resolves crash when saving documents involving large numbers of objects

Other fixes and improvements

PDFpenPro 11.0.2 2019-05-29

Fixes hiding sidebar in full-screen mode

Fixes page up/down keyboard navigation in split view

http://smilesoftware.com/
file:///Users/pjg/Applications/PDFpenPro.app/Contents/Resources/help.help/Contents/Resources/English.lproj/releasenotes.html


Resolves crash exporting to PDF/A and PowerPoint

Resolves crash when highlighting in full-screen mode

Other fixes and improvements

PDFpenPro 11.0.1 2019-05-16

Fixes PayPal purchase

PDFpenPro 11.0 2019-05-15

Split-view mode for editing

New Font Bar for expressive font control

Import scans from Continuity Camera

Customize page-number locations

Add multiple items to the Library at once

Adds option to turn off Guides

Adds Medical/Legal dictionaries for OCR (English language)

Various improvements and fixes

PDFpenPro 10.2.4 2019-04-02

Resolves issue with page change upon save

Other fixes and improvements

PDFpenPro 10.2.3 2019-03-19

Fixes Polygon tool

Fixes allowed space for extra buttons on Editing Bar before they are collapsed

Correctly saves field values of Radio Button groups

PDFpenPro 10.2.2 2019-02-28

Updates OCR engine

Other fixes and improvements

PDFpenPro 10.2.1 2018-11-13

Adds notarization for increased security

Fixes crash at purchase completion

Fixes crash on File -> New -> From HTML…

PDFpenPro 10.2 2018-10-16

Smooths scrolling

Draws thumbnails faster

Supports Mojave dark mode

Increases maximum zoom to 1600%

Other fixes and improvements

PDFpenPro 10.1.2 2018-08-23

Resolves potential hang on launch with specific documents

Other fixes and improvements

PDFpenPro 10.1.1 2018-06-13

Major performance improvements relating to thumbnails and display

Reduced memory requirements for opening large documents

Display progress dialog when adding headers and footers

PDFpenPro 10.1 2018-05-16

Updates files based on last save from any app

Remembers Form Field & Link Highlighting per document

Includes check boxes in Form Field Highlighting

Displays link destination on hover

Adds image opacity controls

Supports AppleScript for:

Batch OCR

Headers & Footers

Page numbers

PDFpenPro 10.0.1 2018-04-17

Restores custom color button functionality



Closes PayPal popup if purchase is cancelled

Ensures PayPal popup appears in front of welcome window

Adds localized help for French, Italian, and Japanese

Resolves some document-specific issues

Other minor fixes and improvements

PDFpenPro 10.0 2018-04-10

Adds watermarks

Insert Headers & Footers

OCR multiple documents in batch (PDFpenPro only)

New Precision Edit tool selects, moves, resizes and deletes line art and text

Improves move & resize of images

Enhances page number styling

Adds larger Library item view

Prettier drawing colors

Adds context menu options

Various improvements and fixes

PDFpenPro 9.2.2 2017-10-17

Resolves issue with export when using Asian languages (PDFpenPro only)

Other fixes and improvements

PDFpenPro 9.2 2017-09-05

Improves OCR performance and accuracy

PDFpenPro 9.1.1 2017-08-25

Fixes cases where Find window can be hidden

PDFpenPro 9.1 2017-07-25

Opens previously-opened documents at same size and position

Add and remove Bookmarks, which appear at the top of the Table of Contents

Other minor fixes and improvements

PDFpenPro 9.0.2 2017-05-16

Ensures black & white scans are stored as 1-bit images

Minor fixes and improvements

PDFpenPro 9.0.1 2017-04-14

Minor fixes and improvements

PDFpenPro 9.0 2017-04-12

Enhances Annotations navigation

Select multiple annotations

Copy text of selected annotations

Delete selected annotations

Includes highlights in list

Enhances Table of Contents editing (PDFpenPro only):

Adds contextual menu

Adds multiple selection support

Combines Table of Contents entries when combining files

Copy Table of Contents entries

Adds export options:

Export to JPEG, PNG, and 1-bit TIFF

Export to flattened PDF

Export in grayscale

Export one TIFF file per page

Export at 72, 200, 300, 600 dpi

Adds horizontal OCR for Chinese, Japanese, and Korean (PDFpenPro only)

Supports removing OCR layer

Create and open links to other files

Adds initial support for forms which perform calculations

Find & Highlight all instances of a search keyword

Adds hand tool for navigation

Magnify using hand tool with Option / Command+Option



Adds line numbering

Adds two additional custom highlight colors

Adds keyboard shortcut for 'Zoom to Width' ⌥⌘9

Supports Print button in interactive forms

Adds visual indicator when navigating Table of Contents

Smoother navigation to Table of Contents entries

Shows full text / tooltips when hovering over related items

Shows resizing handles for items off page edge

Shows current page and count in document title

Print annotation list alone—great for highlights

Improves font smoothing for better readability

Over 100 other usability improvements

PDFpenPro 8.3.4 2017-04-04

Fixes behavior when rotating certain PDFs twice in succession

Allows New From HTML… via HTTP on macOS 10.12 and later (PDFpenPro only)

Resolves potential hang

PDFpenPro 8.3.3 2017-03-14

Fixes potential crash when fonts are not processed properly

Resolves potential crash related to the font panel

Scribbling over a scribble creates a new scribble

Updates launch permission to remain valid for 18 years

PDFpenPro 8.3.2 2017-02-16

Resolves crash on launch due to expired launch permission

PDFpenPro 8.3.1 2017-01-04

Minor fixes and improvements

PDFpenPro 8.3 2016-12-06

Adds Touch Bar support for:

Editing bar tools

Table of Contents (PDFpenPro only)

Other fixes and improvements

PDFpenPro 8.2.1 2016-10-20

Displays first page correctly in print preview

Fixes "selected folder not writable" when scanning on Sierra

Resolves numerous issues on 5K Retina iMacs running Sierra

PDFpenPro 8.2 2016-10-05

Syncs your Library via iCloud for Smile store purchasers

Syncs Library with PDFpen for iPad & iPhone for Smile store purchasers

Supports tabs on macOS Sierra (10.12)

Other fixes and improvements

PDFpenPro 8.1 2016-09-13

Adds new “Snap to Guides” option:

Shows center and edge alignment guides when dragging objects

Snaps objects to guides

Snaps text box to baseline when creating, moving, and resizing

Click and move existing objects while new object tool active

Improves display of self-signed certificates

Preserves tab order after save (PDFpenPro only)

Other fixes and improvements

PDFpenPro 8.0.2 2016-06-30

Resolves occasional incorrect presentation of document colors

Other minor fixes & improvements

PDFpenPro 8.0.1 2016-05-17

Press shift-space to scroll a page up

Improves signature field compatibility with Adobe® products



Other minor fixes and improvements

PDFpenPro 8.0 2016-04-26

Validate digital signatures for authenticity and trust of digitally signed documents

Digitally sign documents using AATL or self-signed certificates

Create a digital certificate for self-signing

Preview and extract file attachments and annotations

Record and playback audio annotations

Measure distances with the measurement tool, including those within architectural

documents

Export PDF to Microsoft® Word (.docx) offline

Create Portfolio documents, combining related files together (PDFpenPro only)

Add and delete file attachments and annotations (PDFpenPro only)

Choose widget styles for radio buttons and checkboxes (PDFpenPro only)

Rearrange tab order of form fields via sidebar drag and drop (PDFpenPro only)

Export PDF to Microsoft® Excel (.xlsx) offline (PDFpenPro only)

PDFpenPro 7.3.4 2015-12-29

Resolves issue with File -> Open command

PDFpenPro 7.3.3 2015-12-15

Adds Services menu support for selected text and single images

Supports OCR of business card size documents

Uses Measurement Units preference when showing page size in Document Info

Resolves case where Correct Text could increase file size

Other fixes and improvements

PDFpenPro 7.3.2 2015-10-08

Fixes crash when opening specific documents

PDFpenPro 7.3.1 2015-09-29

Compatible with El Capitan (OS X 10.11)

Minor fixes and improvements

PDFpenPro 7.3 2015-08-11

Improves scanning performance and reliability

Resolves numerous scanning issues

Fixes to prepare for upcoming releases of OS X

Other minor fixes and improvements

PDFpenPro 7.2.1 2015-07-14

Restores double-click to keep a tool selected

Fixes appearance of Overview button in Scan window

Removes save prompt for unedited graphics files

PDFpenPro 7.2 2015-07-07

Adds new Cloud annotation tool

Adds case-sensitive search option

Adds Editing preference for automatic selection tool switching

Improves popup notes for highlights and stamps:

Adds Edit Note and Delete Note menu commands

Adds Delete Note button

Enhances annotation list:

Shows annotation icons

Wraps text for improved readability

Shows date, author, and location when available

Adds read-only Document Permissions window to PDFpen

Exports new unsaved documents

Other fixes and improvements

PDFpenPro 7.1.1 2015-04-28

Minor fixes and improvements

PDFpenPro 7.1 2015-03-24



Adds formatting options for page numbering:

Font Family

Font Size

Color

Format

Page Range

Create custom stamps

Adds additional stamps: Copied, Faxed, Paid, Scanned

Auto-deskew when performing OCR

Improves German localization

Improves VoiceOver support in PDF forms

Other fixes and improvements

PDFpenPro 7.0.2 2015-02-10

Adds Share button to default toolbar

Fixes a form-related incompatibility with Adobe® Acrobat® / Reader®

Fixes case where signature compresses when resized

Other fixes and improvements

PDFpenPro 7.0.1 2015-01-27

Adds pure color options to color picker

Uses default email reader for File > Mail Document command

Resolves issues with color selection for text and comment boxes

Dismisses file dialog when a document is opened

Resolves issue with Combine PDFs script

Other minor fixes and improvements

PDFpenPro 7.0 2015-01-13

Modern user interface updated for Yosemite

Viewable OCR layer for proofing OCR text from scanned pages

Context-sensitive popup-menus enable quick edits

Performance enhancements for load and save

Compatible with iCloud Drive

Tools remember last chosen colors and properties

Freeform highlighting

Sign PDF forms via interactive signature fields (not digital signatures)

Text fields support combed/segmented display

Correct typos in OCR text layer (PDFpenPro only)

Export to Microsoft® Excel (.xlsx, .xls), Microsoft® PowerPoint (.pptx), and PDF Archive

(PDF/A) formats (requires Internet connection and must be a licensed user, PDFpenPro

only)

Add interactive signature fields to forms (PDFpenPro only)

PDFpenPro 6.3.2 2014-08-19

Fixes to prepare for upcoming releases of OS X

Other fixes and improvements

PDFpenPro 6.3.1 2014-07-16

Improves performance on Mavericks

Fixes crash when scanner is unplugged while PDFpen is running

Fixes potential crashes with the scanning window

Improves editing bar appearance on Yosemite developer preview

Resolves issue with access to tools when search results are displayed

PDFpenPro 6.3 2014-06-10

Adds Text-to-Speech support

Improves save performance, especially with large or complex PDFs

Improves search performance

Restores ⌘5 as keyboard equivalent for Tools -> Text

Improves VoiceOver support for fillable text fields

Improves Accessibility of several user interface elements

Improves performance of Split PDF script

Adds option to skip Create Form Fields alert (PDFpenPro only)

Adds preference to restore all disabled alerts



Adds AppleScript support for owner password, permissions, and selected page

Other fixes and improvements

PDFpenPro 6.2.1 2014-05-06

Adds support for AES-256 encryption from Adobe Acrobat X and later

Adds Open Scripts Folder menu item

Adds support for Zoom In using ⌘+ and Zoom Out using ⌘-

Fixes Combine PDFs script

Fixes Quartz filters

Other fixes and improvements

PDFpenPro 6.2 2014-04-15

Exports plain text and rich text

Select language(s) for Word export to improve accuracy

Drag from the Thumbnail view to the Finder and other apps

Drop multiple pages from Preview's Thumbnails into PDFpen's Thumbnails

Drop Word documents directly into the Thumbnail view

Adds page count field to the document inspector

Adds support for removing the owner password

Supports Automator workflows in the scripts menu (OS X 10.8 and later)

Numerous fixes and improvements

PDFpenPro 6.1.5 2014-02-19

Minor fixes and improvements

PDFpenPro 6.1.4 2014-02-11

Increases PDF page limit to 999 when creating from HTML (PDFpenPro only)

Improves responsiveness when using a tablet with the scribble tool

Resolves possible crash when printing

Other fixes and improvements

PDFpenPro 6.1.3 2014-01-22

Adds new Redaction toolbar buttons (Block Selection, Erase Selection), which can be

installed using View -> Customize Toolbar

Adds support for clickable links from telephone numbers

Adds support for creating tel: links via Create Links from URLs (PDFpenPro only)

Changes the file save command so that it does not allow saving changes to a locked

document

Fixes an issue which causes the Page Up / Page Down key to behave incorrectly when

Continuous scrolling is enabled

Fixes an issue which causes some document pages to appear blank

Fixes an issue which prevents changing the stroke style or stroke width values when

multiple objects are selected

Other fixes and improvements

PDFpenPro 6.1.2 2013-12-17

Improves performance with several classes of PDF document

Reduces memory usage

Minor fixes and improvements

PDFpenPro 6.1.1 2013-11-07

Minor fixes and improvements

PDFpenPro 6.1 2013-10-30

Adds support for PDF stamps

Adds a library of standard business stamps (e.g. Approved, Confidential, Sign Here)

Add and view popup notes associated with annotations, such as highlighting and drawing

objects

Adds support for saving PDFs to Evernote Business notebooks

Adds support for creating form fields for an entire document, in addition to per page

(PDFpenPro only)

Adds Create Links from URLs command to detect and create links (PDFpenPro only)

Adds option to display source URL on pages when creating PDFs from websites

(PDFpenPro only)



Checkboxes automatically created in forms are now borderless (PDFpenPro only)

Opens PDF files with missing or incorrect extensions

Adds QuickLook preview of Library items

Adds menu item and keyboard shortcut to insert selected Library item

Resolves a number of issues related to rotated pages and objects

Other fixes and improvements

PDFpenPro 6.0.5 2013-08-20

Adds option to print "Selected Pages in Sidebar" in print dialog

Adds dictionary lookup on three finger tap (OS X 10.8+)

Supports printing multiple, non-contiguous selections of pages

Supports 'make new page at ...' in AppleScript

Supports enhanced AppleScript printing

Improves performance with encrypted PDFs

Improves performance with PDFs containing inline images

Improves ability to open malformed PDFs

Fixes OCR functionality on Mavericks

Fixes scribble tool on Mavericks

Fixes Populate Script Menu on Mavericks

Other fixes and improvements

PDFpenPro 6.0.4 2013-07-09

Treats PDFs from Print to PDFpen as new, untitled documents

Improves highlighting in documents with irregular word spacing

Resolves cases where pages appeared blank due to unusual coordinates

Resolves a number of issues which prevented opening of specific classes of PDF

Fixes selection on last line of multi-line text fields from Correct Text

Fixes issue with redacting PDFs printed from Chrome

Other minor fixes and improvements

PDFpenPro 6.0.3 2013-05-16

Adds Polish language OCR

Draws annotations when exporting in TIFF format

Pasted plain text now obeys the default font preference

Opens and repairs an additional class of damaged PDF

Fixes Zoom to Width on smaller screens

Fixes internal linking when creating PDF from HTML (PDFpenPro only)

Other minor fixes and improvements

PDFpenPro 6.0.2 2013-04-25

Adds General preference to toggle autosave and versions

Dramatically reduces memory usage

Fixes issues when saving PDF forms

Resolves issues with applying foreground, background, and stroke colors

Respects document permissions for Insert Page Numbers…

Uses default font when automatically creating form fields

Sets multi-line property when automatically creating tall form fields

Improves tab ordering upon automatic form creation

Other minor fixes and improvements

PDFpenPro 6.0.1 2013-03-28

Allows Word export on OS X 10.7 Lion

Preview and QuickLook now respect password-protected PDFs saved by PDFpen

Fixes issues with importing and using Library items

Resolves potential hang when right-clicking in Sidebar

Fixes opening of LaTeX-generated PDFs

Fixes opening of PDF portfolios

Fixes links to PDFpenPro-specific help topics

Allows populating scripts menu on Lion

Other minor fixes and improvements

PDFpenPro 6.0 2013-03-19

Adds editing bar for faster, easier access to tools and properties

Export in Microsoft® Word (.doc, .docx) format (requires Internet connection, must be



licensed user)

Optimized for full resolution viewing on Retina displays

Updates and improves document window appearance

Supports autosaving and document versions

Supports printing lists of annotations

Adds filtering by type of displayed annotations

Adds option to highlight form fields with transparent background

Adds support for re-ordering items in the Library

Syncs Library via iCloud for use with PDFpen for iPhone/iPad (Mac App Store version only)

Adds Russian language OCR

Edit document permissions to control saving, printing, copying, etc. (PDFpenPro only)

Create form fields automatically (PDFpenPro only)

PDFpenPro 5.9.5 2013-02-15

Minor fixes and improvements

PDFpenPro 5.9.4 2013-01-15

Reduces memory usage

Improves ability to open documents not following the PDF specification correctly

Improves OCR error handling

Resolves sandboxing issue with File -> New -> From HTML… on local files (PDFpenPro

only)

Other minor fixes

PDFpenPro 5.9.3 2012-12-05

Resolves issue with occasional incorrect page display

Other minor fixes

PDFpenPro 5.9.2 2012-11-14

Fixes issue with saving some PDF documents

Other minor fixes

PDFpenPro 5.9.1 2012-10-31

Fixes potential hang

PDFpenPro 5.9 2012-10-31

Improves performance by significantly reducing memory usage

Adopts new method to log in to Evernote

Adopts Apple's sandboxing for improved security

Other minor fixes

PDFpenPro 5.8.6 2012-09-26

Fixes scanning on OS X 10.8.2

PDFpenPro 5.8.5 2012-07-28

Fixes scanning on Lion (OS X 10.7)

Fixes case where resampling at lower resolution can result in larger saved file

Other minor fixes

PDFpenPro 5.8.4 2012-07-03

Mountain Lion (OS X 10.8) compatible

Other minor fixes and improvements

PDFpenPro 5.8.3 2012-06-07

Fixes potential crash when highlighting a document with 5.8.2

Fixes silent failure of Check for Update in 5.8.2

PDFpenPro 5.8.2 2012-06-06

Fixes an issue which caused PDFpenPro to crash when opening documents under some

circumstances

Fixes an issue which affected saving under some circumstances

Fixes an issue which caused PDFpenPro to hang when the sidebar was expanded to cover

the entire page area

Fixes an issue which caused PDFpenPro to crash when attempting to cancel PDF from



HTML document creation (PDFpenPro only)

Other minor fixes and improvements

PDFpenPro 5.8.1 2012-05-08

Adds screen width as an initial window size preference

Adds menu and toolbar "Zoom to Width" commands which sets the zoom to fill all

available display width

Improves OCR accuracy by suppressing the use of ligatures

Improves text selection accuracy in a number of cases

Adds a confirmation prompt before allowing the Edit > Reset Form command to proceed

Adds an error recovery prompt when attempting to save a document to iCloud with a

duplicate name

Adds ability to insert text imprints from the library via a double-click

Fixes an issue which caused a gradual shift in color when using text fields

Other minor fixes and improvements

PDFpenPro 5.8 2012-03-27

iCloud folders support:

Move documents to iCloud via drag and drop

Remove documents from iCloud to local management via drag and drop

View contents of folders on iCloud

Create new folders on iCloud via drag and drop

Move documents to different folders on iCloud via drag and drop

Rename folders on iCloud

Fixes some OCR issues

Drops support for 32 bit Intel processors due to adoption of Apple's new ARC memory

management

Other minor fixes and improvements

PDFpenPro 5.7.2 2012-02-22

Fix potential issue with saving primarily on Snow Leopard

Fix localization of page numbering

PDFpenPro 5.7.1 2012-02-22

Signed with Gatekeeper-friendly Developer ID from Apple

Fixes gradual shift in color when using comments

Fixes issue with text tool when object stroke is set to none

Fixes for various documents that did not open successfully

Other minor fixes and improvements

PDFpenPro 5.7 2012-01-25

iCloud support:

View PDFpen documents on iCloud

Open PDFpen documents on iCloud

Move documents to iCloud

Remove PDFpen documents from iCloud to local management

Delete PDFpen documents on iCloud

Rename PDFpen documents on iCloud

Preview PDFpen document content on iCloud

Integrates with PDFpen for iPad

Other fixes and improvements

PDFpenPro 5.6.2 2011-12-14

Adds preference for alert sound on OCR completion

Adds preference for default sidebar view

Adds file size and document size to document info panel

Shows OCR languages in localized form

Improves full screen handling on Lion

Adds menu titles for highlight colors

Fixes handling for some types of interactive forms

Other fixes and improvements

PDFpenPro 5.6.1 2011-10-25

Fixes issue with saving of Table of Contents data introduced in 5.6



PDFpenPro 5.6 2011-10-25

Allows setting the name used with notes and comments

Supports anonymous notes and comments

Adds preference to view document on screen at its physical size

AppleScript access to text of page and document

Separates general and editing preferences

Fixes a number of rotation-related issues

Improves selection accuracy in a number of cases

Eliminates several crashing bugs

Other minor fixes and improvements

PDFpenPro 5.5.1 2011-09-13

Added Bates numbering without leading zeros when digits is 0

Fixed a number of text selection issues

Fixed font setting for text fields (PDFpenPro only)

Added Japanese localization of page numbering

Fixed drawing and positioning issues on first generation (32-bit) Intel machines

Fixed crash when saving forms with text fields on Snow Leopard

Other minor fixes and improvements

PDFpenPro 5.5 2011-08-30

Added robust page numbering via Edit > Insert Page Numbers…

Position page numbers in header or footer and set alignment

Alignment options include ”inside, outside“ for facing page printing

Improved Bates Numbering with user-specified prefix, digit count, and starting

number

Options for number formatting, including letters and Roman numerals

Added initial support for Lion full screen mode

Other minor fixes and improvements

PDFpenPro 5.4.1 2011-07-06

Fix Insert toolbar button

PDFpenPro 5.4 2011-06-22

Extract then edit files from PDF collections / ”portfolios“

Improves Table of Contents editing (PDFpenPro only)

Fixes post-OCR selection in some instances

Other fixes and improvements

PDFpenPro 5.3 2011-05-17

Supports saving with 128-bit AES-128 encryption

Supports saving with 256-bit AES-256 encryption

Supports Unicode passwords (AES-256 only)

Allows setting encryption method when saving via AppleScript

Improves performance when opening large documents

Improves handling of off-spec PDFs

Other fixes and improvements

PDFpenPro 5.2.4 2011-04-13

Fix scripting functionality inadvertently broken in 5.2.3

PDFpenPro 5.2.3 2011-04-13

AppleScript support for creating PDFs from HTML (PDFpenPro only)

Fixes problem with performing Correct Text after saving a document

Other fixes and improvements

PDFpenPro 5.2.2 2011-03-24

Select destination for scans

Includes full Japanese help

Fixes OCR-related hang

Other fixes and improvements

PDFpenPro 5.2.1 2011-01-19



Adds Spanish localization

Improves Italian localization

Fixes performance issue with continuous viewing

Other bug fixes and improvements

PDFpenPro 5.2 2011-01-06

First Mac App Store release

PDFpenPro 5.0.3 2010-11-18

Adds new welcome window

Fixes problem where saving a scanned image can result in a blank page

Fixes problems which can prevent saving under some circumstances

Fixes problem with the naming of buttons in forms (PDFpenPro)

Fixes ability to turn off password protection during save

Other bug fixes and improvements

PDFpenPro 5.0.2 2010-10-12

Reduced memory footprint for large documents

Added AppleScript document property: ”needs OCR“

Fixed potential hang when using Combine PDFs… script

Fixed problem with printing artifacts and clipping

Numerous minor fixes and improvements

PDFpenPro 5.0.1 2010-09-09

Add support for 32-bit Intel processors

PDFpenPro 5.0 2010-09-09

Mac OS X 10.6 (Snow Leopard) only, 64-bit

Faster operation, better capacity to handle larger documents

Multi-core OCR processes multiple pages in parallel

Redact or erase text, including OCR text

Search and replace text

Search and redact text

Forms support list widgets and http submit button

OCR enhanced to handle colored text on a colored or shaded background

Deskew scanned document pages for improved OCR

Change resolution and color depth of a single image or scanned document to reduce PDF

file size

Adjust contrast and apply other effects to a single image or scanned document

Enhanced selection of objects or text by auto-select of needed tool

URL auto-detection when clicking text

Select text within any rectangular region for copying (via option select)

Pinch to zoom via trackpad; zoom by chosen percentage

Measurements shown for rectangular selection and crop

Facing pages viewable with page one shown on the left or right

Print to pre-printed forms via option only to print information added to a document

Scale setting observed when printing

Convert a website into multipage PDF document (PDFpenPro only)

Create list widgets and pop-ups (PDFpenPro only)

Create submit button to submit form data via web or email (PDFpenPro only)

Backend integration enables gathering data from http-submitted forms (PDFpenPro only)

PDFpenPro 4.7 2010-07-06

Added Save to Evernote support

PDFpenPro 4.6.2 2010-04-28

Fixed occasional problem where Correct Text blanks more than it should

Switched to FastSpring for in-product purchases

Other minor improvements and fixes

PDFpenPro 4.6.1 2010-03-31

Improved position accuracy for OCR'd text selection and highlight

Fixed occasional problem with sheet-fed scanners repeatedly returning first page

Fixed occasional failure to draw text annotations

https://www.evernote.com/Registration.action?code=pdfpen


Fixed failure to select text when font has zero ascent and descent

Other minor improvements and fixes

PDFpenPro 4.6 2010-02-23

European language OCR; in addition to English, PDFpenPro supports:

German

French

Spanish

Italian

Dutch

Norwegian

Swedish

Finnish

Danish

Portuguese

Catalan

Miscellaneous improvements and bug fixes

PDFpenPro 4.5.3 2010-12-16

Includes table content in OCR

"Merge Every Other" script

Various drawing fixes

PDFpenPro 4.5.2 2010-11-11

Reduces memory requirements for OCR

Improved loading of newer encrypted PDFs

CMYK images and images in cropped PDF scans no longer hide when saved

Make Transparent Image no longer adds unwanted borders

Locked drawing tools no longer display selection when in use

Miscellaneous improvements and bug fixes

PDFpenPro 4.5.1 2010-10-14

Miscellaneous improvements and bug fixes

PDFpenPro 4.5 2010-09-29

New OCR engine with improved accuracy

New highlight text tool -- select and highlight text in a single action

Scan directly into PDFpenPro from Image Capture or TWAIN scanners (Snow Leopard

only)

Numerous improvements and bug fixes

PDFpenPro 4.2.1 2010-09-11

Fixed problems with opening some PDF documents on Snow Leopard

Fixed Quartz filters on Snow Leopard

Improved click selection behavior on Snow Leopard

Fixed problems with filling some IRS forms

Combine PDFs and Split PDF scripts no longer require Rosetta

Other fixes and improvements

PDFpenPro 4.2 2010-08-12

Added support for documents encrypted with 128-bit AES encryption

Added support for the enhanced print event in AppleScript

Other fixes and improvements

PDFpenPro 4.1.5 2010-07-07

Fixes some geometry problems (primarily with rotation)

Fixes potential crashing bug inadvertently introduced in 4.1.4

PDFpenPro 4.1.4 2010-07-01

Improved display performance for large documents

Added AppleScript document property: ”performing OCR“

Other minor fixes and improvements

PDFpenPro 4.1.3 2010-05-12



Fixes problem with highlight being offset on certain documents

Fixes problem where page disappears when using Correct Text

Selecting entries in the annotations list no longer triggers crop

Other minor fixes and improvements

PDFpenPro 4.1.2 2010-04-07

Mail Document menu item (in the File menu)

Performance improvements

Bug fixes

PDFpenPro 4.1.1 2010-03-18

Sparkle support for in-application updating

Fixes to polygon and round-edged rectangle creation

Fixes for grid snap with continuous view

PDFpenPro 4.1 2010-03-03

Continuous scrolling in both single and facing page views

Edit in facing page view

Edit while continuous scrolling

AppleScript support for OCR

View form field tab order in PDFpenPro

Miscellaneous improvements and bug fixes

PDFpenPro 4.0.4 2010-01-02

Improvements for Axiotron Modbook pen input

Minor fixes and updates

PDFpenPro 4.0.3 2008-12-18

Bug fixes and stability improvement

PDFpenPro 4.0.2 2008-11-12

Command-option to force OCR of whole document

Added Bates numbering to script menu

Changed object transparency to work with Preview

Restored French and Italian localizations

Fixed page size interpretation for high density images

Other minor fixes and improvements

PDFpenPro 4.0.1 2008-10-01

Added preferences for OCR prompting

Fixed accuracy of search selection in columnar documents

Fixed highlight over-drawing problem

Fixed underline positioning

Fixed table of contents editing on Mac OS X 10.4

Other minor fixes and improvements

PDFpenPro 4.0 2008-09-17

Optical Character Recognition (OCR) recognizes text in many scanned documents,

allowing scanned text to be selected, copied, and modified.

Improved User Interface; including a document sidebar with thumbnails, and table of

contents; streamlined properties window; clearer toolbar controls.

Significant file compatibility upgrades.

Import Microsoft Word documents.

Print notes and comments.

Additional mark-up capabilities including underline, strikethrough, and custom highlight

color.

Text imprints can be saved in the Library for reuse.

Create and edit document Table of Contents (PDFpenPro only).

Save as TIFF.

Re-written and improved online help.

Image compression in saved files via ColorSync.

Multiple column text selection significantly improved.

Text color choices separated from graphics.

Custom highlight color Preference.



Scribble tool recognizes and assembles multiple stroke tablet input.

Arrow choices for line endings.

Pattern selection for outlines.

Multiple file selection in import dialog.

New application icon.

PDFpenPro 3.5.2 2008-08-27

Various fixes and improvements

PDFpenPro 3.5.1 2008-08-19

Various fixes and improvements

PDFpenPro 3.5 2008-07-22

Improved ability to open PDFs following newer specifications

Improved ability to open non-standard PDF documents

Resolved several cases of disappearing text when using Correct Text

Resolved several cases of garbled text when using Correct Text

Numerous stability improvements and minor bug fixes

PDFpenPro 3.4.2 2008-06-25

Improved handling of font widths for fonts used frequently for OCR

Fixed occasional crashing bug affecting some bank statements

Other minor fixes and improvements

PDFpenPro 3.4.1 2008-03-20

Minor improvements and fixes

PDFpenPro 3.4 2008-03-18

Fixed problem where fonts or spacing could appear jumbled

Fixed setting font, alignment and color for form fields in PDFpenPro

Improved performance when adding imprints to large documents

Various stability improvements

Improved performance opening documents on 10.4.11 and 10.5.x

PDFpenPro 3.3.2 2008-01-09

Improved support for protected documents

Minor improvements and fixes

PDFpenPro 3.3.1 2007-11-06

Fixed ”Combine PDF“ script under Leopard

Fixed ”Open with PDFpenPro“ workflow item under Leopard

Fixed positioning of markup when page is cropped

Fixed positioning of comments when page is rotated

Improved compatibility with off-spec documents

PDFpenPro 3.3 2007-08-14

Display of highlight, strikethrough, underline, and squiggly text annotations

Display of line, square, circle, ink, and stamp annotations

Preference to lock large images automatically

Printed pages are centered

Various other fixes

PDFpenPro 3.2 2007-06-05

Library of English Proofreading Marks for PDF mark-up

Improved handling of scanned PDF documents

Several other improvements and fixes

PDFpenPro 3.1.1 2007-04-03

Remembers zoom level and page position of previously-opened documents

Respects default font size preference when creating form fields

Minor bug fixes and improvements

PDFpenPro 3.1 2006-11-28

Add, edit, and remove URL and page links in PDFpenPro



Access text formatting attributes via AppleScript

Fixed "Merge Imprints into Page" function

Fixed redraw performance problem introduced in 3.0.2

Other minor fixes and improvements

PDFpenPro 3.0.2 2006-10-24

Facing pages view displays properly

Links now support Border attributes (editable in PDFpenPro)

Correct Text works in encrypted documents which permit editing

Open and Save AppleScript commands accept an optional password

Various minor bug fixes

PDFpenPro 3.0.1
PDFpenPro 3.0.1 was not released for download.

PDFpenPro 3.0 2006-10-10

Edit images - move / resize / copy / delete existing images in PDFs

Correct / modify text - replace text in PDFs with editable text blocks

View table of contents

Select text in multiple columns

Copy rich text - retain fonts and formatting when copying from PDFs

User interface enhancements

PDFpenPro 2.4.2 2006-08-29

Improved selection behavior for PDF images

Improved text location and selection

Fixed problem interpreting Unicode character maps

Single disk image for all languages

PDFpenPro 2.4.1 2006-08-01

Improved UNICODE support

Goto links on PDFpenPro are now followed

Various reliability enhancements

PDFpenPro 2.4 2006-06-28

Support for PDF comments

Display and navigate from a list of comments, notes and imprints

Various other fixes and improvements

PDFpenPro 2.3.4 2006-04-11

Enhanced document compatibility

Updates for password-protected documents on Intel Universal binary

PDFpenPro 2.3.3 2006-03-21

Updates essential for Intel Universal binary

Additional keyboard shortcuts for highlighting, inserting a blank page, and go to page

Various improvements and performance enhancements

PDFpenPro 2.3.2 2006-01-31

Universal Binary (runs native on Intel and PowerPC)

PDFpenPro 2.3.1 2005-10-04

Improves quality of printed imprints

PDFpenPro 2.3 2005-09-20

Improved performance for handling complex forms

Improved interactivity for document display

Improved display performance

Fixes problem with disappearing imprints in affected documents

Various other fixes and improvements

PDFpenPro 2.2.2 2005-07-06

Fixes problem writing annotations to secure PDFs



PDFpenPro 2.2.1 2005-06-28

Open with PDFpenPro directly from the Print dialog

Improved compatibility with off-spec PDF files

Minor bug fixes

PDFpenPro 2.2 2005-05-31

Open secure and password-protected PDF documents *

Save documents with password security

Create multi-stroke freehand imprints

Create multi-line polygon imprints

Add links to URLs and pages in document (requires PDFpenPro)

Follow remote file links

Optimized drawing performance

Improved memory management

Better handling of off-spec PDFs

Minor bug fixes and improvements

PDFpenPro respects PDF document security permissions

PDFpenPro 2.1.1 2005-04-25

Tiger (Mac OS X 10.4) compatible

PDFpenPro now creates Preview-fillable text fields (re-save existing PDFpenPro forms to

enable)

Resolved Tiger-specific crash when adding imprints

Resolved hang with Combine PDF / Split PDF scripts when called from script menu

PDFpenPro 2.1 2005-03-30

View, add, and edit PDF notes

Crop pages

Select and copy rectangular areas

Compress uncompressed images when saving (requires PDFpenPro)

Imprinted images retain compression settings when saved

Further non-spec PDF issues resolved

Performance and stability enhancements

PDFpenPro 2.0.1 2005-02-15

Multi-line text in forms is displayed properly

Size to fit improved for small point sizes

Precisely horizontal and vertical lines display properly

Old-style link annotations function properly

Performance improvements

Stability improvements

PDFpenPro 2.0 2005-01-04

Fill out and save filled-out PDF forms

Create cross-platform fillable PDF forms (requires PDFpenPro)

Search, select, and copy full text of PDF documents

View and follow links in PDF documents

Add highlighting markup to document text

Align objects

Show and snap to grid

Set default font and size for text imprints

Check for updates via Internet

Numerous improvements and fixes

PDFpenPro 1.2.1 2004-06-08

Enhanced speed and responsiveness of text operations

Improved precision and responsiveness of freehand drawing tool

Prints at 100% scale unless specified in Page Setup

Split PDF script fixed

Unexpected scroll-to-top fixed

Numerous issues with non-spec PDFs resolved

PDFpenPro 1.2 2004-03-17



Freehand drawing tool for making your own scribbles

Library palette of built-in vector drawings, your images, and your scribbles

View and edit PDF document info

Rotate page(s)

Open multi-page TIFF files (and other graphics files)

Ruler support for text imprints

Right-to-left multi-page view option

Double-click to set default tool

PDFpenPro 1.1 2004-02-10

Hand tool for scrolling

Combine PDFs and Split PDF scripts (droplets)

Improved drawing speed

Outline border for text imprints

Improved font and bounds size for default text imprint

Slimmer text cursor

Better handling of non-spec PDF files
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Help: Demo Version, Purchase Information
The PDFpenPro demo is the unregistered full version, and allows the use of all features except for

Microsoft® Word, Excel, PowerPoint, and PDF/A export. For more info, and document export

samples, check our website. Microsoft® Excel, PowerPoint, and PDF/A export are PDFpenPro

only.

Time Limit: The demo has no time limit.

Demo Features: The demo will stamp the Smile logo on all saved and printed documents. Once

you purchase and register the app, re-save the documents to remove the logo from the document

and its subsequent printouts.

PDFpen: $79.95 
(Family Pack: $99.95, for up to 5 computers in one household)

(Office Pack: starting at $249.95, register 5 seats in one office location. Larger Office Packs available.)

PDFpenPro: $129.95 
(Family Pack: $159.95, for up to 5 computers in one household)

(Office Pack: starting at $374.95, register 5 seats in one office location. Larger Office Packs available.)

How to buy PDFpen or PDFpenPro:
It's easy to buy PDFpen or PDFpenPro from the application itself. Here

are the steps:

1. Download PDFpenPro 12 from our site.

2. Launch it. It will notice your previous version and offer to check for a free

upgrade. If you are not eligible for a free upgrade click on “Buy an upgrade license”

for upgrade pricing.

3. Go through the screens to purchase.

4. Complete your purchase and PDFpenPro will register with your new license.

Or buy now from our web store: PDFpen and PDFpenPro
Registered users of version 11 .x and earlier qualify for upgrade pricing.

Updates within a version number are free to registered users. For example, registered users of

version 12 .0 can get the version 12 .1 update for free. Smile reserves the right to change the

update policy.
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Help: View Options and Getting Around a PDF
PDFpenPro lets you control how you view your documents.

Page View Types
The default view in PDFpenPro is Page View, where a single page is visible at a time. The other

option is Facing Pages view where two pages are visible at once, like a book. Change between

these views by clicking on the Sidebar item in the toolbar . Choose which view your documents

automatically open with by choosing Preferences > General > Default view. With Facing Pages view

your document can open with the first two pages visible together, or with the first page alone on

the right hand side.

Split View
Split the screen into two panes to compare different pages of a document side by side.

1. In the Sidebar, select a page you want to see in the split view.

2. Choose Window > Split and select Vertically or Horizontally, or Go > Go to Page in Split

View. Go to Page in Split View typically defaults to your last selected view (vertically or

horizontally).

Edits are made in the main view. Split view is in view-only mode. Click a pane to make it active.

Pages selected in the active pane will have a blue border against a light grey background. In the split

view, scroll, select a different page or change the zoom level of the active pane without affecting

the other pane. To select a different page in the split view, type in a number.

To adjust the size of the pane, hover over the dividing line between the views until you see the

two-sided arrow, then click and drag the divider to the left or right.

To return to single-page view, choose Window > Split > Remove Split.

Continuous Scrolling
Scroll continuously through the pages of your document instead of paging through one or two at a

time. This is also a default mode. Turn this off or on by choosing View > Continuous, or by clicking

on the Sidebar menu item. This setting persists across newly opened documents.

Rotate Pages
Go to the View menu for the rotate page options: Rotate Right (clockwise)(Command+R) or

Rotate Left (counter-clockwise)(Command+Shift+R). You can rotate the current page, or rotate

multiple pages by selecting their thumbnails in the Sidebar.

View Page Numbers
View > Page Numbers is turned on by default. Notice a small gray box with a page number in the

bottom right corner of each page and thumbnail. Also, view the current page, and total pages, next

to the document title at the top of the window.

Zoom In and Zoom Out
In Page View, you can zoom in and out of your page or document with the Zoom In and Zoom

Out controls   in the toolbar.

You can also zoom in or out using the Scale item in the toolbar. Click into the Scale field to change

the percent manually. If the Scale item is not in your toolbar, add it by Customizing your Toolbar.

In the Sidebar, you can increase or decrease the size of the thumbnails with the slider 

 found at the bottom of the Sidebar.
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From the View menu there are also options for:

Full screen mode (Command+Control+F).

Zoom to Fit (Command+Option+0) which fits your entire page in your current window

size

Zoom to Width (Command+Option+9) which zooms the width of the page to fit your

current window width.

Actual Size (Command+0) which displays your document at 72 pixels per inch. On a

retina display this means the visible size is about the same as on a regular screen, but with

a clearer image.

Magnifier Window
In Page View, use a Magnifier window to zoom into a specific area of a document and view it in

greater detail.

1. From the menu, choose Window > Magnifier to launch the Magnifier window.

2. Direct your cursor to an area on the page you want to view in closer detail within the

window.

3. To adjust the magnification:

Use the   controls to zoom in or out.

Drag the slider to a specific percentage.

4. To view another section of a page, move your cursor to the desired area. The section will

reflect and magnify in the Magnifier window.

Tips:
The actual size for a PDF is usually 100%.

PDFpenPro remembers window settings. The Magnifier window will automatically open on launch

if it was open in a previous session.

Page Up and Page Down

To move to the next page of the document, use the Up / Down buttons    in the menu bar.

Use the keyboard to shift up and down through the pages of your document.

Move up
Function-Up arrow or Shift+Space

Move down
Function-Down arrow or Space

Go to A Specific Page
1. From the menu, choose Go > Go To Page... (Command+Option+G)

2. Type a page number in the small drop down window which appears and click Go To or

press Return. You will navigate to that page.

Manually input a destination page number using the Page item to the toolbar. Navigate to a page by

typing in a page number. If this item is not in your toolbar, add it by Customizing your Toolbar.

Scrollbars
Scrollbars appear when the document view cannot fit the contents of the page in the current

window. You can click and drag the scrollbars to go to the part of the document that is hidden, or

use gestures on your track pad.

Hand Tool 
While zoomed in, use the Hand Tool to pan around your document. Zoom in by pressing the

Option key, zoom out with Command+Option.

Sidebar

Switch between Sidebar views using the Sidebar button  in the tool bar. For more on the

Sidebar see Sidebar.

Thumbnail View
PDFpenPro displays thumbnails of all the pages in your PDF in the Sidebar.

Click on a thumbnail to navigate to a page.



The thumbnail size can be enlarged or reduced using the slider control at the bottom of the

Sidebar.

The Sidebar width can be increased by dragging the border between the Sidebar and the Page

View.

Annotations View
View a list of all the annotations you've made to the document, including objects such as highlights,

notes, and comments. Adjust which annotations you see using the Show menu at the bottom of the

Sidebar.

Click on one of the listed annotations to navigate to its location. Double-click on it to both

navigate to it and select the annotation.

Shift-click to select multiple annotations in the Sidebar and delete them.

Copy the text of annotations such as highlighted text, comments, and notes. To do so:

1. Click on an annotation entry in the Sidebar.

2. In the Edit menu choose Copy As Text. You can now paste the content where you

choose.

If you want a list of all annotations, print out the list via File > Print > Append Annotations

Summary.

Table of Contents View

Use the Sidebar button  to switch to Table of Contents View.

Bookmarks are listed at the top with Table of Contents below. Click on one of the Table of

Contents entries to navigate to it, a blue indicator helps you determine where you are in the Table

of Contents.

Copy the text of an entry:

1. Click on an entry in the Sidebar. Shift-click to select all the entries.

2. In the Edit menu choose Copy As Text. You can now paste the content where you

choose.

Right-click, or Control-click, to access the context menu and navigate the Table of Contents more

quickly.

Search

Click on Find  in the menu bar to open the search window. Enter a search term or keyword,

and you will see a list of results. Click on any of the results to navigate to it.

Pages Right-to-Left
View > Pages Right-to-Left is turned off by default. It is only active in the Facing Pages view, and

allows facing page ordering to be re-arranged for reverse-viewing such as needed in Japanese

language.

Grid
To help you align objects on a page go to Arrange > Show Grid or Arrange > Snap to Grid. Set the

spacing of the grid in General Preferences.

Ruler
For a measurement guide show a ruler along the top of the Page view area by choosing Format >

Text > Show Ruler (Command+Control+R). With a specific text box selected for editing, the ruler

also provides controls for Formatting Text such as options to adjust style, alignment, spacing, and

create numbered or bulleted lists.

Measurements

To measure the distance between two objects on the page, click the Measurements tool  in the

toolbar. Click and drag between objects to see the distance. Set the units in General Preferences.

If your drawing already has units built in, such as a drawing generated from an architectural

program, then those units will be shown using the measurements tool.

Tab Bar



View multiple documents in the same application window through tabs.

1. Choose View > Show Tab Bar.

2. Click on the + button at the far right corner of the tab bar to open a new tab.

3. Choose File > Insert to insert a new file into the open tab view.

To disable tab view, choose View > Hide Tab Bar.

To make tab view your default, adjust your settings in Apple’s System Preferences > Dock and

change the value next to “Prefer tabs when opening documents” to “Always.” Close PDFpen and

relaunch. New documents should open in a new tab in PDFpen rather than in a new window.

Gather Documents in a Single Tabbed Window
PDFpenPro supports viewing multiple documents in a single tabbed window as introduced in

macOS Sierra.

Combine several open windows using Window > Merge All Windows.
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Help: Toolbar
Visible by default, hide and reveal the toolbar by choosing View > Hide Toolbar (Command+Shift+B). PDFpenPro provides a set of default

toolbar items. Customize the items on the toolbar in a couple different ways.

Go to View > Customize Toolbar…

Control-click on the toolbar and select Customize Toolbar… from the menu.

A. Sidebar menu  (Sidebar)

B. Zoom In/Out   (View Options)

C. Scale Zoom in and out by percentage. (View Options)

D. Page Up/Down   (View Options)

E. Page Type a page number to get to a page. (View Options)

F. Find  (Searching Within a PDF)

G. Correct Text  (Correcting Text)

H. Add Highlighting, Underscore, Strikethrough  

(Markup: Highlighting, Underline, Strikethrough)

I. Insert Image  (Adding Images)

J. Share Document  (Sharing Documents

K. Open Inspector  (Inspector)

L. Open Library  (Library)
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Help: Editing Bar
Visible by default, hide or reveal the editing bar by choosing View > Hide Editing Bar, (Command+Shift+E).

Tools appear in Touch Bar on supported Macs.

Select Text 

Select text to copy or edit with correct text (Working With Text); use this tool to fill interactive PDF forms (Filling Out PDF Forms). This tool is

selected by default when a document is opened.

Edit Tool 
Select an image, text box or other object to move, resize, or delete (Editing Images, Formatting Text).

Precision Edit Tool 
Double-click the Edit tool to turn on the Precision Edit tool. Select otherwise un-selectable objects and images. Select text line by line. Move, resize,

or delete (Editing Images, Formatting Text).

Highlight Text Tool 
Drag over text to apply highlighting, strikethrough and other markup (Markup Text).

Select Rectangle Tool 
Select a region of a page. The region can be copied and pasted, or the page can be cropped to the selected region. (Selecting Part of a Page).

Measurements 
Measure the distance between two objects on the page. (Measurements).

Hand Tool 
Pan around a document with a click and drag. Zoom in by pressing the Option key, zoom out with Command+Option.

Note on all following tools
For the Markup, Drawing, and Form Elements tools, you can double-click a tool to lock it on and use it continuously. Clicking the Select (arrow)

tool will unlock your choice of tool. To make the continuous use feature automatic, go to Preferences > General. Preferences

Tools remember their last chosen colors and properties.

Markup Tools 

Text Tool 

Insert a text box. (Adding Text)

Scribble Tool 

Freehand drawing tool. (Adding Objects: Scribbles, Lines and Shapes)

Notes Tool 

Add a note to a PDF. (Adding Notes and Comments)

Comments Tool 

Add a comment to a PDF. (Adding Notes and Comments)

Cloud Tool 

Add a comment cloud to a PDF. (Adding Notes and Comments)

Linking Tool 

Add a link to an external URL. (Adding Links)

Attachment tool

Attach a file to a PDF. (Attachment tool).

Audio annotations tool 

Add an audio note to a PDF. (Audio annotations).

Add color to the text, stroke, or fill of these objects using Object Properties (see below).

Drawing Tools  (Adding Objects: Scribbles, Lines and Shapes)

Polygon Tool 
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Draw polygonal shapes

Rectangle Tool

Ellipse Tool

Line Tool

Rounded Rectangle Tool

Callout Tool 

Add callout text box to a PDF. (Adding Notes and Comments)

Add color, stroke style, and stroke weight to any of these objects using Object Properties (see below).

Form Elements  ( PDFpenPro Only; Creating PDF Forms)

Text Field Tool

Checkbox Tool

Radio Button Tool

Choice Field Tool

List Field Tool

Signature Field

Submit Button Tool

Object Properties (Adding Objects: Scribbles, Lines and Shapes)

Tools remember their last chosen colors and properties.

Object Color

Set the Fill and Stroke color of objects. Pick the font and background color of a text field.

Stroke Style

Used for dotted and broken lines. Set the Start and Ending of a line to create an arrow.

Stroke Weight

Set the line weight of a scribble, line or border of a text field.
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Help: Font Bar
Reveal the Font Bar by choosing View > Show Font Bar. The Font Bar will appear directly under

the Editing Bar. To hide the Font Bar, choose View > Hide Font Bar.

 

Font
The current font will display. Click the down arrow to expand the menu and select a new font.

Size
The current font size will display. Click the up or down arrows to expand the menu and select a

new size, or click on the font size directly (a blinking cursor will appear) and type in a custom size.

Style
The current typographical emphasis (if any) will display. Click on Bold, Italic, or Underline to

select or deselect. Style selected will be highlighted in blue.

Alignment
Current alignment will be displayed. Click to choose the alignment: Align Left, Center, Align Right,

Justify.

The Font Bar will display the typeface, size and other properties of the selected text or newly

created text imprint. (See Working with Text, Formatting Text).

Alternatively, typeface, size, and style is accessible by choosing Format > Font > Show Fonts

(Command+T). Justification is accessible by choosing Format > Text.

Font Matching
PDFpenPro uses the macOS font matching machinery. PDFpenPro asks for the best match, and

what it returns depends entirely on what is available on a user’s system. Adding more fonts on the

macOS level improves matching. No software will be able to create font information from scratch

that is neither present in the PDF nor available on the macOS.
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Help: Sidebar
The Sidebar appears on the left side of your document. There are two ways to show or hide the

Sidebar:

Click the Sidebar button  in the toolbar and select any option except Hidden.

Choose View > Show Sidebar (Command+Shift+D).

Sidebar Display Options
Hidden sidebar
Hide the sidebar for a simpler viewing experience. Click any other option in the Sidebar

menu to reveal it again.

Thumbnails
View the pages of your document in thumbnail form. Click on a thumbnail to navigate to

that page. Use the slider at the bottom of the sidebar to change the thumbnail size. (See

View Options) For other thumbnail uses, such as reordering pages and combining

documents, see Working With PDF Documents.

Table of Contents
View and navigate a Table of Contents. Alternately, go to View > Table of Contents.

Skip to a page by clicking on an entry. A visual indicator notes the current location.

Right-click, or Control-click, to use the context menu to expand or collapse the entries.

(See Creating and Editing a Table of Contents). Bookmarks are listed at the top of the

Table of Contents in the Sidebar. (See Bookmarks). In PDFpenPro, use the action button

 at the bottom of the sidebar to create and edit a Table of Contents. Alternately,

go to Edit > Table of Contents for a list of Table of Contents editing shortcuts. (See

Creating A Table of Contents)

Annotations
Click to reveal a list of annotations made to the document. Annotations include objects

such as comments, scribbles, highlights, and other items. Click on an entry to navigate to

it, and double-click to select it. Use the Show menu at the bottom to filter which types

of annotations appear in the sidebar. To add your own annotations see Adding

Comments and Notes.

Attachments
Attach a file to your PDF. See Attachments.

Form Fields
View a list of all form fields. Drag to re-order and set a new tab order. See Edting the

Tab Order.

Single Page
A single page is on view at a time.

Facing Pages
Pages are viewed in facing page pairs, as in a book. The cover page can be viewed in a

pair or alone; see General Preferences.

Continuous view
Scroll through the pages of your document instead of paging through one page at a time.
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Help: Inspector
Use the Inspector to align objects and access document metadata information. PDFpenPro also

allows you to specify form element properties and edit document permissions.

To display the Inspector, click the Inspector button  in the toolbar or choose Window >

Inspector (Command+Option+I).

Inspector Tabs
Alignment
Align selected objects horizontally and vertically (Shift-click to select multiple objects to

align). Distribute three or more selected objects evenly spaced horizontally or vertically.

Form Elements Properties (PDFpenPro only)
Edit properties for text fields, checkboxes, radio buttons, choice fields, list fields, and

submit buttons. (See Creating PDF Forms).

Document Information
Access the metadata of a document. Add Title, Author, Subject and Keywords; view Date

Created, Date Modified, File size, Page Count, Page size, and Application and Producer

used to create the document.

Document Permissions (PDFpenPro only) 
Set a password and allowable modifications to the document by a user. (See Permissions).
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Help: Library
The Library stores scribbles, images and text for quick access and reuse. Drag Library items to the

current document to insert them.

Choose the Library button in the toolbar to open the Library palette (Command+Y).

Library Tabs
  

Built-Ins
From the Library palette, drag and drop a built-in shape onto a document page, or double-

click to add a built-in centered on the current page. Built-ins are also available from the

Drawing Tools menu. (See Editing bar)

Custom
Store objects for future use including objects created with the scribble tool, any drawing tool

objects (polygons, lines), markup tool objects (text boxes, comments), or images (pictures,

signatures).

Proofreading marks
Drag these proofreading marks into your document. If you select a stroke color in properties

first, any proofreading mark you drag into your document will adopt that color.

Stamps
Drag stamps into your document. Choose from Standard Business, Sign Here, Dynamic

Stamps or User Defined. The name in a dynamic stamp is set in the Editing preferences.

Saving Items in the Library for Reuse
Save frequently-used images and objects in the Library.

1. Make sure the Library palette is open. (Window > Library or Command+Y).

2. Select an object (scribble, shape, image, signature or text).

3. Click the plus (+) button  at the bottom of the Library palette.

4. Choose Add Selected Imprint. Your selection will be added to the Custom tab.

The next time you want to use an item saved in the Library, you can just drag it from the Library onto

the page.
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Library Location
The items in your library are stored in the Library file located here:

[HOME]/Library/Containers/com.smileonmymac.PDFpenPro/Data/Library/Application

Support/PDFpenPro/Library

Note: if iCloud is turned on, later versions can sync the Library with iCloud. Please check your

application version and iCloud settings.

Increase Library Size 
Increase the visual size of items in the Library window. This does not effect the size of the item once

added to a document. Click the button  to toggle regular and large views.

Combining Multiple Scribbles or Drawing Objects into a Single Library Item
1. Select the scribbles and/or drawing objects you want to store as one: shift-click on multiple

items or drag your mouse over the items you want to select.

2. Click on the plus (+) button  at the bottom of the Library palette.

3. Choose Add Selected Imprint. A single item combining the selected objects will be added to

the Library.

This feature is useful if you want to save a signature created with more than one scribble.

Importing an Image File to the Library

1. Click on the plus (+) button  at the bottom of the Library palette.

2. Choose Add File…

3. From the dialog box that opens, choose the image file you want to add to the Library.

Use this for image files that are not already in your document. If the image is already in your document,

you can select it and choose Add Selected Imprint.

Creating a User Defined stamp

1. Click on the plus (+) button  at the bottom of the Library palette.

2. Choose Add Custom Stamp…

3. From the dialog box that opens, choose a stamp label, type (Dynamic, Sign Here or Standard

Business), color scheme and click OK to create a new custom stamp with the chosen values.

The Custom Stamp Preview image area shows what the new custom stamp should look like.



Reorder Custom Library or User Defined Stamp Items
Reorder the items you have stored in the Custom library or in your list of User Defined stamps with

drag and drop. Click and drag an item up or down the list. A blue line indicates where it will drop.

Removing a Library Item
1. Select the item you want to remove

2. Click on the minus (-) button  at the bottom of the Library palette.
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Help: Preferences
Open the Preferences by selecting PDFpenPro from the menu bar, and choosing Preferences...

from the drop down menu (Command+comma).

General Preferences
Define 100% scale as:
Choose how to display your documents using either of the following options:

1 point equals 1 screen pixel size
Display a document at different dimensions depending on the screen's resolution.

Size on screen equals size on printout
Display a document at the same dimensions regardless of the screen's resolution.

Initial window size:
Set PDFpenPro to open a document sized to page height, screen height, or screen width.

Default zoom:
Set PDFpenPro to open documents at 100%, 150%, Fit to Page, or Fit to Width. (View

Options).

Initial sidebar mode:
Choose the initial display mode of the sidebar when opening a new document. (Sidebar).

Default view:
Choose Single Page or Facing Pages. (View Options).

Remember last page viewed for each document:
Reopen a document to the same page where you left off. Checked by default.

Enable autosave and versions:
Enable automatic file saves and support for versions. Checked by default.

Always show the File Open dialog on launch:
Allow the "File Open" dialog window to appear every time the app is launched.

Lock PDF/A archive documents when open 

Make a PDF/A document un-editable when open.

Enable clicking on detected links:
Enable the automatic detection of context links such as emails and phone numbers.

Enable JavaScript 

Allow JavaScript to run in a document. Forms which perform calculations require

JavaScript to function properly.

Restore display of all warning alerts

Editing Preferences
Default Font:
Choose the default text formatting (font and size) of a text field. This includes text fields

from Markup Tools, like the Text Field and Comment tools. To change the default, click

the Select… button, and choose a new font or size from the Font window.

Keyboard Increment:
Choose the keyboard increment, that is, the amount the arrow keys will move an object.

Gridline every:
Set the distance between gridlines. Go to the Arrange menu to turn on and off Show Grid

and Snap to Grid.

Measurement units:
Select Keyboard Increment and Gridline units, either points, millimeters, or inches.

Show Guides:
Check if you would like keep red alignment guidelines visible. (Snap to Guides).

Automatically switch selection tools:
Check this option if you want PDFpenPro to automatically switch between the Select Text
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and Edit tools based on the location of mouse clicks. For instance, if you click on an image,

PDFpenPro will automatically switch to the Edit tool so that you may move or resize the

image. Conversely, if you click on text, then PDFpenPro will automatically switch to Select

Text tool. If you have this feature unchecked, the currently selected tool will always

remain active regardless where you click on the page.

Keep tools selected after use:
Check this option to keep the Markup, Drawing, and Form Element tools active for

continuous use, rather than switching back to the Edit tool after each use. To quit the tool

while in continuous use, click on another tool. If you have this feature unchecked, the tool

will stay active for a single use, then revert back to the Edit tool. To activate continuous

use from single use mode, double-click on the tool.

Lock images:
PDFpenPro can automatically lock large images that it detects. This is useful when working

with scanned documents. Default is set to Lock images '“Large enough to fill the page.”'

Can be set to Always or Never.

Custom highlight colors:

Create custom highlight colors which will appear in the Highlight button . (See

Markup: Highlighting, Underscore, Strikethrough and Squiggle)

Annotations:
When checked, the characters placed in the Name: field appear as the name property of

any new annotations added to the current document.

Name:
The name that will be used as the name property of new annotations. 

Defaults to the currently logged-in full user name.

OCR
Prompt for OCR when opening a scanned document:
Checked by default.

Perform OCR when selecting text on a scanned page:
Checked by default.

Rotate & deskew pages automatically when performing OCR
Automatically detect and adjust rotated and crooked pages upon OCR.

Languages to recognize:
Check which languages you want to be recognized by OCR.

OCR completed sound:
Select the sound to be played after a successful OCR.

OCR failed sound:
Select the sound to be played after a failed OCR.

Update
Check for Updates:
PDFpenPro can check for updates when it is launched. Set how often you want to check

for updates (hourly, daily, weekly, monthly). Uncheck for Never. Updates within a major

version number are free to registered users of that version. For example, registered users

of PDFpenPro 12 .0 can get the PDFpenPro 12 .1 update for free. (We reserve the right to

change our update policy.)

Include anonymous system profile information:
Allow information (macOS version, Mac model, CPU, etc.) to be sent anonymously during

update checks.
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Help: Opening and Creating PDF Files
PDFpenPro is a document-based application. With it you can open existing PDF documents and

create new ones.

Opening an Existing PDF
1. Choose File > Open (Command+O).

2. Find the PDF you want to open, select it and click Open.

You can also drag a PDF's file icon and drop it on the PDFpenPro icon in the Dock to open it.

To re-open a recently opened document, choose File > Open Recent and select from the list.

Creating a New One Page Document
1. Choose File > New > From Stationery from the menu. (Command+N).

2. Choose a page orientation and design in the New Page window.

3. After making a selection in the New Page window, click "Choose" or tap the Return/Enter

key to confirm.

4. Begin editing your new page.

5. Choose File > Duplicate (or File > Save As) to give the PDF a name.

Last selected paper style and orientation will remain as default during the session. Users can also

duplicate paper styles through copy and paste.

Creating a New Blank PDF
1. Choose File > New > Blank Document from the menu.

2. Choose a page orientation in the New Page window. By default, a blank page will be

selected.

3. Click "Choose" or tap the Return/Enter key to confirm.

4. Insert a page into the PDF by choosing Edit > Insert Blank Page (Command+Option+B), or

drag a page thumbnail from an open PDF and drop it in.

5. Choose File > Duplicate (or File > Save As) to give the PDF a name.

Creating a New PDF from Pages of an Existing PDF
1. Open an existing PDF file.

2. In the Sidebar, select the thumbnails of the pages you want to include in the new PDF.

3. Choose File > New > From Selection (Command+Shift+N). A new PDF file is created

from the pages you selected.

Creating a New PDF from a Section of a Page of an Existing PDF
For when you want to create a PDF containing only a specific portion of an existing PDF page.

1. Open an existing PDF.

2. Navigate to the portion of the page you want in a new document.

3. From the toolbar, select the Select Rectangle tool . Position your mouse, and drag

over the area you want as a new PDF.

4. Choose File > New > From Selection. A new PDF file is created from the portion of the

page you selected.

For information on opening a document stored in iCloud see iCloud.
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Help: Searching Within a PDF
Search the contents of a PDF by keyword.

1. Click the Find button  in the toolbar to open the search window, or choose Edit >

Find (Command+F). The search window will open.

2. Enter the search term(s) in the search field. A list of the pages containing the results will

appear.

3. Navigate to a result by clicking on it.

The search results can be expanded or collapsed from view via the Show Results button.

Find and Highlight, Find and Redact or Find and Replace from Keyword
Search
From a search you can highlight, redact, or replace keywords and phrases. Access these options a

couple of ways.

Choose Edit > Find > Find and Redact… or Find and Replace…

Open the Find window (Command+F) from the menu bar for highlight, redact, or replace.

From the Find window:

1. Type a search term into the Find field. Results will appear listed below.

2. From the Find popup menu select Replace, Redact, or Highlight. Further options will

appear.

Highlight: Choose a highlight color. Select one result and click Highlight to

highlight that instance. Click Highlight All to highlight all instances of that search

term.

Redact: Choose a style, Block (replace the search term with a black block) or

Erase (replace the search term with white out). Select one result and click Redact

to redact that instance. Click Redact All to redact all instances of that search term.

Replace: Type the replacement term in the Replace field. Click Replace to

replace one instance of the search term. Click Replace All to replace all instances

of the term.

Note: If there is any sensitive information in the document metadata, you must

remove it manually in the Inspector under the Document Information tab

(Command+Option+5). Find-and-Redact and Find-and-Replace do not scan the

metadata.
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Help: Undo/Redo
PDFpenPro allows you to Undo edits made to your document.

To undo a change, go to Edit > Undo (Command+Z).

To redo a change you've undone, go to Edit > Redo (Command+Shift+Z).

Note: Undo is no longer possible:

After you Save.

After you switch between Page View and Facing Pages view. (Page View Types)

After changing pages when not in Continuous view mode. Continuous view is the default

and can be reached by choosing View > Continuous.
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Help: Working With Text
Selecting Text
Selected text can be copied and pasted into other applications. Text attributes (formatting, font,

columns) are copied along with the text and match the original formatting as much as possible.

Text is automatically selected in columns if your document is formatted that way.

1. Make sure the Select Text tool  is active.

2. Click and drag your mouse over the text you want to select.

Note: A PDF document that is a scan of a printed page is a bitmap image of text and will not have

selectable text. It is treated as an image of text and not actual text.

When you try to select text in such a document it will ask to perform optical character recognition

first. For details on generating selectable text from a scan, see "Using OCR (Optical Character

Recognition)."

Tips on Selecting Text
Double-click to select a word; triple-click to select a whole line.

Select text across more than one page by changing pages and shift-clicking into the new

page to extend the selection.

Select all the text in a document by choosing Edit > Select All (Command+A).

Moving Text Blocks
Select a text block to move or delete using the Precision Edit tool. This is different than a text box

where you can edit the text it contains.

1. Double-click the Edit tool to activate the Precision Edit tool .

2. Click on the word or line you would like to move or remove. Then drag it around, resize

it, or delete it.

Correcting Text
PDFpenPro lets you edit or delete original text in your PDF document.

1. Select the text you want to correct using the Select Text tool .

2. Click the Correct Text button  in the toolbar.

3. The selected text is replaced with a text box that can be edited or deleted, just like any

other text box.

Tips on Correcting Text
Correct Text works best on small portions of text in the same line or paragraph.

The results may not match the underlying text exactly. In particular, fonts and spacing will

vary at times. PDFpenPro will match the font in the document with a font in your macOS

provided Font Book. If you do not have the same font, it chooses the closest match.

Adding Text
Inserting a Text Box

1. Select the Text tool  in the toolbar.

2. Insert a text box in one of two ways:

Click anywhere on the page to insert a text box. The box will expand to hold the
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text you add.

Click and drag to create a text box with a specific size. The text will automatically

wrap to the size of the box.

3. Start typing. You can also paste text from the Clipboard that you've previously copied.

4. Use the handles to resize the text box; the text will automatically wrap.

Tips for Adding Text
By default, the Text tool reverts to the Edit tool after inserting text. Double-click the Text

tool to keep it selected. This is especially helpful when Filling Out Forms.

Option-dragging a text box with the Edit tool will make a copy of the box. This can save

time if you are repeating a style.

Choose Edit > Wrap Text to change the wrapping mode on any text box.

Choose Arrange > Snap to Guides to snap into position a text box on the same baseline as

existing text. (See Snap to Guides).

Special Characters
Superscript and Subscript are located in Format > Font > Baseline.

Other Characters are located in Edit > Emoji & Symbols. (Also through the Fonts window

> Tools menu > Characters.)

Formatting Text
Changing Typeface or Text Size

1. Select specific text you want to format or use the Edit tool to click on a text box and

select the whole thing.

2. Choose View > Show Font Bar. (See Font Bar).

3. The Font Bar will reflect current typeface, size and style for the selected text. Use the Font

Bar to select new properties.

Alternatively, choose Format > Font > Show Fonts from the menu (Command+T). When the

system Font panel appears, make the desired changes in the panel.

Changing Text Color
1. Select specific text you want to format or use the Edit tool to click on a text box and

select the whole thing.

2. Go to the editing bar and locate the Object Properties menu. If the editing bar is not

visible, go to View > Show Editing Bar (Command+Shift+E).

3. Click on the Object Color item . From the drop down menu choose one of the

designated colors, or choose Other Text Color… to pick a custom color.

Changing Text Justification
1. Click on a text box to select it.

2. Choose View > Show Font Bar. (See Font Bar).

3. The Font Bar will reflect current justification for the selected text. Choose the alignment:

Align Left, Center, Justify, Align Right.

Alternatively, choose Format > Text and choose the alignment: Align Left, Center, Justify, Align

Right.

Changing Line Spacing
Choose Format > Font > Baseline and select either Default, Raise or Lower.

Tips:
Library: Frequently-used text, including formatting, can be saved to the PDFpenPro Library for

reuse.

Ruler: With a specific text box selected for editing, the ruler also provides controls for formatting

text such as options to adjust style, alignment, spacing, and create numbered or bulleted lists.

Markup: Highlighting, Underscore, Strikethrough and Squiggle
PDFpenPro offers several ways to markup text by adding highlight colors, underscoring,

strikethrough, and squiggle. The options are available by clicking and holding down on the Highlight



button in the toolbar ; by choosing Format > Highlight, where the shortcuts are listed; or

by using the context sensitive menu made visible by right-clicking.

The markup will attempt to follow the line of the text exactly. If the text is not selectable text, or

the highlight is not used on text, the highlight will follow the path of the cursor. Text can be made

selectable using OCR.

Change the color of a Strikethrough, Underline or Squiggle
1. Select the Highlight tool (Command+3) tool to add a strikethrough, underline, or squiggle.

2. Select a color using Object Color  in the Object Properties palette.

The chosen color will remain the default color for that tool unless changed.

There are several means of performing markups:

Markup selected text
1. Select some text.

2. Hold the mouse down on the small arrow on the Highlight button  to view the

markup choices, then pick one.

Alternately, right-click or Control-click on the selected text. A context menu will

appear with options for applying a highlight color, underscore, strikethrough, or

squiggle. Click on an option.

3. A highlight color, underscore, strikethrough, or squiggle will appear over the selected text.

Use the Highlight Text Tool
1. Access the highlight tool in one of three ways:

Choose Tools > Highlight Text Tool (Command+3).

Click the Highlight Text Tool  in the editing bar.

Click the Highlight button in the toolbar . Click and hold the button for

color and markup options.

2. Drag over some text. The current highlight choice in the toolbar‘s Highlight button is used

to markup the text. Choose a different markup from the Highlight button, and the

Highlight Text tool becomes active.

Add a Note to a Highlight
1. Double click on a highlighted section of text. You will see the text window of a Note

appear.

2. Type into the text window. When you are done the Note icon will appear next to the

highlighted text. Optionally close the text window by clicking the red button in the upper

left, or pressing the Escape key.

For more on adding Notes, see Notes, Comments and Links.

Delete a Highlight
1. Select the already highlighted text.

2. Click on the Highlight button in the toolbar and click Remove. This will remove all

highlights from the selected text. Alternately, access the Remove function by choosing

Format > Highlight > Remove (Command+Shift+Option+0).

Creating Custom Highlight Colors
You can create 3 custom highlight colors in the application Preferences.

1. Go to the PDFpenPro menu > Preferences > Editing (Command+comma).

2. Click on the color box  at the bottom of the Editing Preferences window.

3. The macOS System Colors window opens; select a color.

Redacting Text
You can block out text (black out), or erase it (white out) with the redact function.

1. Select the text you wish to redact.



2. In the menu, choose Format > Redact text. 

Choose Redact Text – Block if you want that text blacked out.

Choose Redact Text – Erase if you want a blank space in place of the text.

You will not be able to redact text that has already been made editable using the Correct Text

button . That text can instead be deleted.

Redact an Area
Redact a rectangular area of your document.

1. Choose Tools > Select Rectangle tool (Command+4). Drag a rectangle over an area of

your page.

2. Choose Format > Redact Text - Block, or Erase. All of the content in the rectangle area is

securely redacted.
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Help: Images, Signatures, Objects, Imprints
Adding an Image

1. Click the Insert button  in the toolbar.

2. In the dialog that opens, navigate to the image you want to insert and click Open.

3. The image will be placed in the center of the page by default.

Tips on Adding an Image
You can drag-and-drop an image from any folder on your computer directly to the PDF

page.

You can also drag an image from Safari, iPhoto, or other applications that support image

drag-and-drop, and drop it into PDFpenPro.

You can use the Clipboard to copy and paste an image to the PDF page. Click on the page

you want the image to appear in before pasting. If no page is selected, and the keyboard

focus is on the Thumbnails in your Sidebar, the image will appear on a new page among

your Thumbnails.

Adding a Signature
Insert a scanned image of your signature into a PDF just as you would any other image. When you

do, it's often necessary to make the background of the signature transparent.

See Signing a Document.

Editing Images
Edit images original to the PDF or added by you.

Once an image has been selected in a document, you will notice new items on the editing bar

which pertain just to image editing. Use the action button  in the editing bar to access many

of the options below. If you don't notice new tools in the editing bar, you may have selected a link

over the image instead of the image itself.

1. Select the Edit tool (Command+2) .

2. Click in an image to select it. If you cannot select the object, try to select it with the

Precision Edit tool, though not all the following options will be available.

3. Once an image is selected, you have several options:

Delete the image by choosing Edit > Delete from the menu.

Copy the image by choosing Edit > Copy from the menu. The image can now be

pasted to another page or another PDF.

Move (using the Edit tool) the image by dragging it to another location.

Using the Snap to Guides option in the Arrange menu will help position the image.

(See Snap to Guides).

Move (using the Precision Edit tool) the image and the image stays on the

same layer in the PDF. This means, if the image was on a layer behind the text, the

image will remain behind the text as you move it. Moving with the Precision Edit

tool will also keep the file size from increasing, unlike with the Edit tool.

Resize the selected image by dragging the selection handles. Hold down Shift

while you do to keep the image proportional. You can also choose Edit > Expand

Image to Fit Page; the image will be enlarged to its maximum size that fits on the

page.

Crop the selected image. See Cropping Images below.
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Make Transparent Image. See Adding A Signature.

Increase the size of the image to fit the edges of the page by choosing Edit >

Expand Image to fit Page.

Adjust the color (contrast, saturation, etc.) of the image as well as apply effects

by choosing Edit > Adjust… (See Adjust Image).

Resample to change the resolution and color depth of an image or document by

choosing Edit > Resample… (See Resample Image).

Deskew or make fine adjustments to the tilt and exposure of an image by

choosing Edit > Deskew and Adjust… (See Deskew Image).

Note: In order to make an image transparent that is part of the original PDF, you must first move

or resize it.

Cropping Images
1. Select an image and choose Edit > Crop Image… or click the Crop icon in the image

editing portion of the Editing bar.

2. The crop area starts at the edges of the image. Find and drag the corner or side handles of

the crop area to resize and reshape.

3. Click on and drag your crop area around your image to move it into position. The crop

area displays the dimensions on each side in units. Select the type of units in General

Preferences.

4. Click Crop, and the image will crop to the area specified.

5. Click Crop and Scale to Fit and the cropped image will have the proportional height and

width of the original image.

Adding Objects: Scribbles, Lines and Shapes
Change the color or line weight of any of the following lines or objects using the Object Properties

menu in the Editing bar.

Reveal the drawing tools by clicking the Drawing Tools tab in the Editing bar.

Scribble Tool

Found in the Markup tools  menu the Scribble tool lets you draw freeform scribbles

with the mouse or a tablet. Click the Scribble tool in the Editing bar. Now click and drag

the mouse on a page to make a scribble. 

Note: When you release the mouse button, your scribble will be smoothed. If you don't

want your scribble smoothed, hold down the command key when you release the mouse.

Polygon Tool
Create polygonal shapes by clicking to place endpoints of each section of the shape you

want. To complete the shape, click on the first point, or, double-click.

Rectangle Tool
Click and drag to create a rectangle.

Ellipse Tool
Click and drag to create an ellipse.

Line Tool
Click and drag to create a line. To make a line into an arrow, or add some other shape to

the ends of a line, select the line and then go to the Object Properties menu in the Editing

bar and click Stroke Style. A menu will drop down with options for Line Start and Line

Ending.

Rounded Rectangle Tool 
Click and drag to create a rounded rectangle.

Callout Tool 
Click and drag to create a callout. A callout includes a text box with a leader line with an

arrow.



Tip: With all the above tools you can double-click a tool to lock it on and use it continuously.

Click the Edit (arrow) tool to unlock your tool. To turn the automatic continuous use feature on

or off, see General Preferences for details.

Object Properties: Fill, Stroke, Endpoints
Locate the Object Properties menu in the Editing bar.

Object Color (Text, Fill, Stroke)
Choose a stroke color or fill color for a shape or line from one of the included palette

colors, or choose Other Stroke/Fill Color… to select a custom color from the macOS

provided Colors Palette.

Stroke Style (Endpoints)
Choose from a variety of stroke styles, solid or dotted. To make a line into an arrow,

select the line, then click the Stroke Style menu item. The drop down list will show a

variety of endpoints that you can add to the start and end of the line.

Stroke Weight
Choose a line width for a shape or line from the standard palette of weights, or choose

Other to make a custom selection.

Saving Items in the Library for Reuse
You can save frequently-used images and objects in the Library. See Library for details.

Arranging Images and Objects
Use the options in the Arrange menu to manage images and objects that overlap. Select the item

that you want to manipulate and choose:

Move Forward
Move to Front
Move Backward
Move to Back
These four choices let change the order in which items are stacked, e.g. the frontmost

item will be visible on top of the others.

Lock
Locks the selected item so that it can't be moved or edited. Not all objects remain locked

after saving. Text objects remain locked after saving. Images are locked depending on the

setting in General Preferences.

Unlock All
Unlocks all items that have been locked.

Snap to Guides
Easily align objects by snapping them into place with visible guidelines. Text boxes will snap

to the baseline of existing text. Other objects show guides at center and edges. Turn on

the snap option with Arrange > Snap to Guides. Hold down the Command key to quickly

toggle snap on or off. Select settings in Preferences.

Snap to Grid
Snaps items to a grid when placed on the page. The grid increments can be specified in

Preferences.

Show Grid
Toggles the visibility of the grid on and off.

Show Ruler
Makes visible a ruler along the top of the Page area. Used as a rough size guide, this setting

is not in the Arrange menu, but in Format > Text > Show Ruler (Command+Control+R).

Measurement tool
Measure distances between objects using Measurements.

Imprints
An imprint is an object added on top of the existing PDF page that is able to be edited, moved,

resized, etc. When 'editing' a PDF, the original text and images in the document are not really

edited, parts of the page are removed and imprints are added on top that match the original, it's

those imprints you edit.

The exception is when using the Precision Edit tool to move objects. In that case the orignial



objects are moved.

Imprints are rendered into the drawing layer of a document. Other PDF editors won't be able to

edit the imprints unless they are capable of manipulating the content of a document.

For example, Preview and Acrobat Reader can manipulate annotations like Comments, Notes and

form fill-ins, but not imprints or other document content.

Use the Precision Edit tool to select and edit line art, which includes certain borders and

registration marks found in documents. The Edit tool can only select and edit images.

Print Imprints Only: When checked in the Print Dialog, this print option will not print any of

the original document text, it will only print information added to the document, like Text,

Comments, Notes, and Scribbles. With this feature you can position Text to fill in a pre-printed

form, because only the answer fields will print.

Also see Print Annotations List Only.

Watermarks
Stamp pages in your document with a watermark, such as “DRAFT” or a company logo.

Watermarks can be images or text boxes and appear behind the text of the document. Only one

watermark is allowed per page. Different watermarks can be applied to alternating pages using

even and odd distribution.

Add a

watermark to a document
1. Add an image to your document. See Adding an Image.

2. From the menu bar choose Edit > Watermark > Convert to Watermark.

3. In the following dialog, select your preferences, then choose Apply. Select from an array of

options, including:

Page range: specify a custom page range

Even / odd pages: apply only to the even pages or only to odd-numbered

pages

Image opacity: make the image semi-transparent

Rotation: rotate a text box 45° or 90° degrees

Remove a watermark

1. Select some pages. To do so, set the Sidebar  to Thumbnail view and:

Shift+click to select a range of thumbnails

Command+click to select non-consecutive thumbnails

Select a single page and press Command+A to select all pages



2. Choose Edit > Watermark > Remove Watermark from Selected Pages.

Edit a watermark
Watermarks cannot be edited directly. First remove the current watermark, then apply a new

version.
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Help: Signing Documents
There are a few ways to sign a PDF document.

Sign a document with an image of your signature. This is most common. There are several

ways you can apply it.

Sign a document securely with a digital signature using a digital certificate. Certain legal and

governmental bodies require this. See below.

Adding a Basic Signature
Insert a scanned image of your signature into a PDF just as you would any other image. When you

do, it's often necessary to make the background of the signature transparent.

1. Scan your signature, crop it to size, and save it as an image file, such as JPEG, TIFF, or

PNG.

2. Drag and drop the image

into the PDF from Finder.

For other ways to insert an

image see Adding an Image.

3. With the signature

selected, choose Edit >

Make Transparent Image...

4. In the window that opens,

use the eyedropper to click

on the background color of

the signature. Usually this

means anywhere on the

white part. The Tolerance

slider can adjust how sharp

the edge of the the

transparency appears.

5. Click Make Transparent.

6. If your signature appears

too thin, choose Edit >

Undo, and repeat Step 3

with decreased tolerance.

7. Use resizing handles, with

the Shift key held down to

constrain proportions, to

resize the signature to fit

appropriately.

Tips for Adding A Signature
Once you've added your signature to a PDF, you can save it in the Library to reuse in the

future. (See Library).

If your scanned image is too large, you can crop it first. (See Cropping Images).

Using an interactive signature field
PDFpenPro supports using the signature fields which come in certain forms. An interactive

signature field aids in signing a form by providing a larger space to sign, and multiple ways to sign.

1. Click in the signature field to open the field’s signing area.

2. There are several ways to add a signature in this field, including drawing with with the

mouse, drawing on the trackpad, or dragging in a signature from the library.
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Digital Signatures
The goal of a digital signature is to provide a way for

the document's recipient to verify the identity of the

one who signed it, and that nothing has changed since

it was signed. To accomplish this, digitally signing a

document means applying a digital certificate to the

document. This certificate is the way to ensure the

integrity and authenticity of the document once

signed.

Integrity 

Proves the document has not been altered.

Nothing has been added, changed, or

removed since the document was signed.

Authenticity 

Proves the document originated from a specific individual or organization.

Digital Certificates
When you open a document which was digitally signed, PDFpenPro will validate the digital

certificate it was signed with and inform you whether the certificate is from a trusted source.

In order for you to digitally sign a document you need to obtain a digital certificate from a

certificate provider, such as those on the Adobe Approved Trust List (AATL). This may involve

purchasing a certificate, and may involve installing software from the provider.

What is a Digital Certificate?
A digital certificate is a piece of data, typically stored in files or on an external device, such as a

secure USB dongle, which contains:

Identity information for a person or company, for example, a name, country and location

Public key, used to sign documents

Digital signature, typically of a trusted third party

Along with your digital certificate you create a private key. Unlike the public key which helps make

up the certificate, the private key is typically stored on your system keychain where other secure

items, like passwords, are stored. Documents are signed using this private key. Your digital

certificate, containing your public key, along with your identity information and the digital signature,

is embedded in any documents you sign. It's safe to give your public key to others. You must keep

your private key secure.

Security
Digital certificates have a "chain of trust", which begins with a root certificate, may include

intermediary certificates, and ends with the certificate of a person or company. Adobe's

applications only trust signatures with root certificates from the Adobe Approved Trust List

(AATL).

Just because a certificate is verified as trusted does not mean it always must be so. For example, if

you lose your laptop or your secure USB dongle someone else could gain access to your private

key, which means the integrity of the certificate has been compromised. In an event such as this it's

possible to revoke the digital certificate.

Issuers of digital certificates maintain systems to check whether a digital certificate has been

revoked or remains valid. One system is called the Online Certificate Status Protocol (OSCP), and

the other is Certificate Revocation Lists (CRLs). PDFpenPro is capable of checking both, as

necessary.

Validation
When you open a PDF with a digital signature using PDFpenPro, the following steps occur to

validate the signature:

The signed content of the document is validated to ensure it hasn't changed

The signature of the certificate is tested to ensure the certificate is valid

The chain of trust of the certificate is validated

The expiration date of the certificate is considered

The certificate is checked against OSCP or CRLs to ensure it hasn't been revoked

https://helpx.adobe.com/acrobat/kb/approved-trust-list2.html
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https://en.wikipedia.org/wiki/Online_Certificate_Status_Protocol
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States of Validation
When you view a signed document in PDFpenPro the document will display one of three states.

Pass 

You see a green badge in the upper right corner of the document. The document passed

all of the above tests.

Conditional Pass 

You see a yellow badge in the upper right corner of the document. The document passed

all of the above tests, but the root certificate is not trusted.

Fail 
You see a red badge in the upper right corner of the document. The document failed one

or more of the above tests.

Hover your cursor over the validation icon badge for information about the validation. Click on it

to see the certificate details.

Signing a PDF with a Digital Signature
1. Add a signature field to the document. Either click the Signature Field button  in the

Form Elements palette of the editing bar, or choose Tools > Signature Field from the menu

bar.

2. Double-click on the signature field and draw your signature.

3. Click Apply Digital Signature and choose your digital certificate from the Select Signing

Identity drop down menu. 

You may see several options in the drop down list, look for the issuer of your certificate. 

You may be prompted to allow PDFpenPro to access your keychain. You must allow this

to apply the digital signature.

Please note that only digital certificates from Adobe Approved Trust List (AATL) issuers are

trusted by the Adobe applications.

Smile's testing, as of February 2016, suggests that only DigiCert and GlobalSign offer digital

certificates compatible with use on macOS. Each requires special driver software from the

certificate issuer.

Self-Signed Certificates
It's possible to create your own digital certificate, rather than obtaining one from an issuer. This is

called a self-signed certificate. Self-signed certificates do not have a chain of trust and cannot be

revoked. Therefore, they are not suitable for establishing the authenticity of a document. They're

only suitable for verifying document integrity.

Create a Self-Signed Certificate

1. Add a signature field to the document. Either click the Signature Field button  in the

Form Elements palette of the editing bar, or choose Tools > Signature Field from the menu

bar.

2. Double-click on the signature field and draw your signature.

3. Click Apply Digital Signature. In the menu which appears click Create A New Identity.

4. Enter your Name and Email address and click Create. Now you can select your new

certificate from the list.

Sign or Send PDFs with DocuSign® (PDFpenPro only)
Users of DocuSign's electronic signature (e-signature) service will be able to sign and send

documents from PDFpenPro. To log in to DocuSign from PDFpenPro, a user must either already

have an account with DocuSign, or can sign up for an account at www.docusign.com. Once signed

in, PDFpenPro will remember your credentials for a seamless workflow.

Sign a Document with DocuSign
1. Choose File > DocuSign > Log in to DocuSign.

2. Click "Continue" to log in.

3. Enter your log in credentials.

4. A browser window will open with DocuSign's Sign workflow and include your PDF loaded

and ready to sign.

Send a Document for Signatures Using DocuSign
1. Choose File > DocuSign > Log in to DocuSign.

https://helpx.adobe.com/acrobat/kb/approved-trust-list2.html


2. Click "Continue" to log in.

3. Enter your log in credentials.

4. A browser window will open with DocuSign's Send for Signatures workflow.

5. From PDFpenPro choose File > DocuSign and upload the document you want signed.

Documents signed or sent with DocuSign are:

Encrypted.

Maintains an audit trail.

Does not require additional software installation.

Are legally binding in the United States and most other countries.

DocuSign offers high-level security standards and e-signature regulations compliance. Learn more

about e-signature legality in the United States and around the world. DocuSign is authorized by the

Federal Risk and Authorization Management Program (FedRAMP) for use in government.

What is an electronic signature? Digital signatures refer to adding your signature and verifying

authenticity, while electronic signatures usually refer to collecting other signatures. An electronic

signature is a legally binding signature for signing an electronic document or record and, according

to the E-Sign Act, is equivalent to a handwritten signature.
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Help: Notes, Comments, Links, Bookmarks and
Attachments

Adding a Note

1. Click the Markup item  in the editing bar to reveal the markup tools. Click on the

Notes tool .

2. Click in the page location where you'd like to place a note. The note is inserted as a small

icon with an attached collapsible text window.

3. You can leave the text window open or closed depending on how you want it to appear

when you open your document. Using either the Edit Tool or the Select Text Tool you

can double-click on the note icon to open or close its text window. Alternately, close the

text window using the Escape key. Set the name along the bottom of the note in

Preferences > Editing > Name. (See Preferences)

A note can be selected by clicking on it with the Edit Tool (arrow) . Once selected, you can

reposition it by dragging.

Delete a note by selecting it and choosing Edit > Delete, or press the delete key.

Adding a Comment

1. Click the Markup item  in the editing bar to reveal the markup tools. Click on the

Comments tool .

2. Click in the page location where you'd like to place a comment. You can also click and drag

initially in order to size the comment when you place it.

3. Once your comment is placed, just type over the text that appears.

4. With either the Edit Tool or the Select Text Tool as the current tool, you can double-click

a comment to edit it.

Adding a Callout

1. Click the Drawing item  in the editing bar to reveal the drawing tools. Click on the

Callout tool .

2. Click in the page location where you'd like to place a callout text box. You can also click

and drag to size the text box.

3. Once you've placed your text box, direct the accompanying leader line with an arrow to a

specific location on the page you want to single out.

4. Type in the text box to add text.

Select a callout by clicking on it with the Edit Tool (arrow) . Once selected, you can

reposition it by dragging.

Delete a callout by selecting it and choosing Edit > Delete, or press the delete key.

http://smilesoftware.com/


Tips on Adding Notes, Comments, or Callouts
You can double-click a tool to lock it on and use it continuously. This is helpful when

adding multiple notes and/or comments. Click the Edit (arrow) tool to unlock your tool

(Command+2). To turn the automatic continuous use feature on or off, see General

Preferences for details.

Use the Object Properties menu to adjust the color and styling of your comment text box.

(See Object Properties).

Printing Notes and Comments
Comment boxes will print where they appear within the PDF. Notes will print below the bottom

margin of each page like a footnote; the text of the page will be reduced to allow this.

1. Choose File > Print.

2. In the Print dialog box open the expanded dialog box by clicking Show Details. Check Print

Comments and/or Print Notes.

Print Imprints Only: When checked, this print option will not print any of the original

document text, it will only print information added to the document, like Text, Comments, Notes,

and Scribbles. With this feature you can position Text to fill in a pre-printed form, because only the

answer fields will print.

For more information on imprints, see Imprints.

Append Annotations Summary: When checked, this print option will cause an additional

annotations summary section to be printed after the end of the document itself. This annotations

summary section lists all the annotations (notes, comments, highlights and others) that are present

in the document, sorted by page order.

While the annotation summary is added to your printed document, it is not added to the original

document, and is discarded once the Print Dialog has been closed. If you would like to view or

save a copy of this summary, you can use the Print Dialog options PDF > Open PDF in Preview or

PDF > Save as PDF…

Print Annotations List Only: Found under Append Annotations Summary in the print dialog.

When checked, this print option will not print any of the original document, it will only print a list

of annotations added to the document, similar to the Annotations view in the sidebar. Included

items are Text, Notes, Comments, Links, Highlights, Attachments, and Sound attachments.

Adding Links

Adding a Link to a URL

1. Click the Markup item  in the editing bar to reveal the markup tools. Click on the

Link tool .

2. Click URL, then click and drag to place the link.

3. Once a link is placed, the Set Link window appears. Enter the destination URL.

Adding a Link to an Email

1. Click the Markup item  in the editing bar to reveal the markup tools. Click on the

Link tool .

2. Click URL, then click and drag to place the link.

3. Once a link is placed, the Set Link window appears. Enter "mailto:" followed by the email

address in the URL destination field:

mailto:[email]

Example: mailto:support@domain.com

Adding a Link to Another Page

1. Click the Markup item  in the editing bar to reveal the markup tools. Click on the



Link tool .

2. Click Page, then click and drag to place the link.

3. Once a link is placed, the Set Link window appears. Enter the destination page number.

Adding a Link to Another PDF

1. Click the Markup item  in the editing bar to reveal the markup tools. Click on the

Link tool .

2. Click File, then click and drag to place the link.

3. Once a link is placed, the Set Link window appears. Browse your hard drive for a file to

link to.

Editing Links

Select a link by clicking on it with the Edit (arrow) tool  (Command+2). Once

selected, you can then drag a link around the page to reposition it.

Delete a link by choosing Edit > Delete, or press the delete key to remove a selected link.

Resize a link via the selection handles at its corners.

Change a link's properties i.e. where it links to, by double-clicking on it with the Edit

(arrow) tool.

Follow a link, or test it‘s link location, by clicking on it with the Select Text tool

(Command+1).

Creating Links Automatically (PDFpenPro only)
1. Open a document which has one or more URLs in the text. Some examples of acceptable

URLs are:

www.apple.com

support@domain.com

2. Next, choose Edit > Create Links from URLs. All URLs will be converted to hyperlinks.

Edit using the Editing Links steps listed above.

Bookmarks
Bookmark pages in a PDF for fast navigation. View bookmarks at the top of the Table of Contents

in the Sidebar .

Add a Bookmark
1. Select a page.

2. From the menu bar choose Edit > Bookmarks > Add Bookmark, or click on the  Add

Bookmark button in the Toolbar. (See Toolbar). In PDFpenPro only, edit the name of the

entry just as you would any Table of Contents entry.

Remove a Bookmark
1. Select the entry in the sidebar.

2. Choose Edit > Bookmark > Remove Entry, or Control+click on the entry for the context

menu, then choose Remove Entry. Alternatively, click on the Cog button  at the

bottom of the sidebar and select Remove Entry.

Attachments
Attach files to your document. To link to an other document see Adding Links.

Read and Extract Attachments

View a list of all the document's attachments by clicking on the Sidebar  and choosing

Attachments .

View an attached file by double-clicking on it in the sidebar.



Right-click on the file to extract it and save it or to preview the contents.

Adding File Attachments

(PDFpenPro only)

1. In the Markup tools  palette click Attachment .

2. Click anywhere on a page in your document. A menu will appear where you can search

and select the file you want to attach.

If you plan to add several attachments, consider adding a text box (Command+5) or comment

(Command+8) next to them to note the name of the file.

This method will result in both the attachment and a paperclip annotation on the page which you

can position next to the relevant text.

To create an attachment without an annotation:
1. Right-click, or control-click, in the sidebar area while in Attachment view. Alternately, click

on the Cog button  at the bottom of the sidebar.

2. Choose Attach Files…

Delete File Attachment (PDFpenPro only)
1. Right-click, or control-click, on the file listing in the sidebar. View attachments in the

sidebar by choosing Attachments after clicking Sidebar .

2. Choose Delete Attachment from the menu.

Adding Audio Attachments

1. In the Markup tools  palette click Audio annotation .

2. Click on the page of your document. In the menu which appears either record a note or

annotation by clicking the red record button, or select a file on your computer which you

have previously recorded.

Once added, click on the audio annotation icon on the page to listed to the recording.

Note: not all PDF apps support attachments and audio annotations, and a PDF re-saved in an app

without support for this feature will erase the annotations. This includes Preview in El Capitan and

earlier.
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Help: Filling Out PDF Forms
There are two different kinds of forms that you can fill out using PDFpenPro, interactive forms

which have built in fillable form fields, and non-interactive forms that are just scanned documents

without built-in form fields.

Interactive PDF Forms
These forms come with interactive fields, making it easy to tab through fields and enter text. Some

other interactive fields which function in PDFpenPro are signature fields and calculation fields.

NOTE: Calculations in forms are performed with JavaScript. If you do not want JavaScript running

in a PDF, you may turn off support for it in Preferences > General > Enable JavaScript.

1. Make sure that the Select Text tool  is chosen (Command+1).

2. Click on a form field. A blue border appears around the field.

3. Fill in the field by typing.

4. Use the Tab button to move to the next field.

5. To check a checkbox or select a radio button, just click on it.

Non-interactive forms
Turn a non-interactive form into an interactive one with PDFpenPro to create active fields for you.

See how in Creating PDF Forms.

1. Select the Text tool  (Command+5).

2. Click on the areas of the form you want to fill in. A text box appears.

3. Type the information.

Tip: You can double-click a tool to lock it on and use it continuously. This will help you to fill out

the whole form without having to switch between tools. Click the Edit (arrow) tool, or any other

tool, to unlock your tool. To turn the automatic continuous use feature on or off, see General

Preferences for details.

Saving Your Form
When you're done filling out the form, choose File > Save. PDFpenPro saves with the information

you added, allowing you to edit the form later without losing any work.

Signing a Form
Add a signature, or a secure digital signature, to your completed form either by importing a

signature, drawing one with the scribble tool, or using an interactive signature field which is

sometimes included in interactive forms. For details see Adding a Signature.
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Help: Scanning a document
Scanning in PDFpenPro requires a scanner supported by the Image Capture application. PDFpenPro 12 also supports scanning with Continuity Camera

(requires macOS 10.14 and iOS iOS 12 or higher).

The usefulness and ease of working with scanned content depends a lot on the quality of the scan, and also on the bulk of the scanned material in terms of

document size. The larger the document, the more unwieldy and longer it takes to process. Keeping scans small enough to meet all your needs is key to

document performance. Some setting recommendations are highlighted below.

Scanning from PDFpenPro
Choose File > Import from Scanner. You'll see the following Scan window interface:

Scanning from Continuity Camera
1. In PDFpenPro, open a document, or choose File > New > One Page Document.

2. Choose File > Import from iPhone or iPad > Scan Documents.

3. Use the camera on the iPhone or iPad to begin scanning.

4. After scanning, tap Save. Scans will appear in PDFpenPro.

Before scanning, check the following:

Mac and iOS devices are in close proximity.

Bluetooth is turned on in both devices.

Sign into iCloud on both devices using the same Apple ID.

Kinds of Scan
The kind of scan chosen has the biggest impact on file size and what is stored:

Text:
Black and white, 1-bit, smallest file size, good for text documents. A single letter-size page at a resolution of 300dpi (dots per inch) will be anything

from 75k to 200k in size.

Grayscale:
Choose 256 gray levels or thousands. 256 gray levels should be more than adequate in most cases. Good for text documents with photos or

diagrams that are not color. Generally this scanning mode is either 8 or 16 times larger than Text, so expect a single page at 300dpi to be 1MB-

2MB in size.

Color:
Choose millions or billions of colors. Millions of colors will yield approx 4MB per page at 300dpi, billions considerably more.

Note: Moving from Text to Grayscale can sometimes allow you to drop the resolution and still yield excellent quality. Something you might scan at

300dpi as Text may come out fine at 200dpi in Grayscale, or in color. Levels of gray or colors often make up for loss in resolution. Experimentation can

help to achieve trade-offs of resolution and grayscale or color against file size.

Another setting that effects the file stored is the Format setting. This lets you set the image encoding stored in your document. Generally TIFF will be the

largest and will not compress well for grayscale or color. TIFF is desirable for when Text is the kind chosen. JPEG is the setting you should use for

compressing photographs. Otherwise, the general setting for most purposes is PDF.

Settings listed in the Scan window below the Format menu are scanner-specific.
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Scan Preview
A preview of the page in the selected scanner is automatically created when you open the Scan window. PDFpenPro automatically sets the size and

position of the page based on that preview. You may prefer to adjust it to letter or A4 size. Letter is 8.5 x 11 inches (215.9 x 279.4 mm), and A4 is 210 ×

297mm (8.27 x 11.69 inches). If you do adjust the size, you'll also want to drag the outline area to fit the entire page.

Scanning
Once you're done with your settings click "Scan" to scan your document. Once scanned, a new document will open containing the scanned page. To

continue scanning, change the page in the scanner, and click "Scan" once again. This new scan will be added to your document. Press Cancel or close the

Scan window when you have finished.

The "Detect Separate Items" box can be used to scan each outlined part of the preview page separately. In general use you will leave this box unchecked,

but it may be helpful to separate unrelated content on a page.

Adjust, Resample, Deskew
To compress a scanned document, see Saving and Compressing File Size.

If you want to alter, enhance, or otherwise adjust a scanned image or document, look under the Edit menu to find these options:

Rotate & Deskew Page Automatically detect and adjust rotated or skewed pages before or after OCR. To rotate or deskew multiple pages in

a document, hold down the Shift key and click to select pages in the Sidebar (see Sidebar), or click the first page of the document and choose Edit

> Select All to select all pages. With multiple pages selected, Rotate & Deskew Page will switch to Rotate & Deskew Pages. For whole documents,

hold down the Option key to switch from Rotate & Deskew Page to Rotate & Deskew Document.

Adjust Image… For images, not for pages or documents. It opens the Image Edit panel which enables you to adjust the color (exposure,

contrast, saturation, etc.) of the image as well as apply effects. Go to Edit > Adjust Image…

Resample Image… Reduce a file's size by changing the resolution and reducing the depth of color. Select a specific dpi or switch the color to

grayscale or simpler. Go to Edit > Resample…

Deskew and Adjust Image… Make fine adjustments to the “skew,” or tilt, of the image, page, or document selected, as well as adjust

contrast and exposure by choosing Edit > Deskew and Adjust Image…
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Help: OCR (Optical Character Recognition)
OCR (Optical Character Recognition) is the process of converting a bitmap image of text (like a

scanned document) into text that can be selected, copied and searched by PDFpenPro and other

text editing software. Once the text has been recognized by OCR, it is placed on an invisible layer

above the image of text that you can see. When you copy text, the text is copied from this invisible

OCR layer. OCR technology will not produce a perfect rendering of the bitmapped text. You will

need to proofread and edit the text that results from OCR.

Using OCR in PDFpenPro
1. Open a scanned PDF in PDFpenPro.

2. An alert box opens with the message:

"This document appears to be scanned. Would you like to perform optical

character recognition (OCR) on it? OCR will allow you to select the text."

You have three options:

Cancel:
No OCR will be performed.

OCR Page:
OCR will be performed on the current page.

OCR Document:
If your document has multiple pages, OCR will be performed on all of the pages.

Pick which languages are recognized by OCR in Preferences > OCR.

While PDFpenPro is performing the OCR, a progress bar will appear. The operation can take a

few seconds or much longer, depending on the size and contents of the scanned document.

To perform OCR manually, choose Edit > OCR Page. PDFpenPro commences to perform the

OCR operation and the progress bar appears.

Batch OCR (PDFpenPro Only)
OCR multiple documents at a time.

 

 

1. From the menu bar choose File > OCR Files.

2. In the OCR Files window select some documents to OCR. Either drag and drop files into

the window, or choose Add PDFs.

3. Once the list of documents is ready, click Perform OCR.

Progress
As each file completes, its progress indicator turns green, indicating success. Yellow or red means

OCR failed. If a yellow or red circle appears next to the file name, either try again or send the

document to support for assistance.

The documents will OCR in the background as you continue working in PDFpenPro. Add more

documents to the list anytime. Each document saves back to its original file.

OCR continues even if you close the window. Reopen the window from File > OCR Files.

A chime sounds once the full list has completed. A list of completed files remains in the window.

Remove completed entries with Remove.

Selecting, copying and correcting OCR Text
Once OCR is finished, the document’s text can be edited like any other text. To make visible text

http://smilesoftware.com/
http://smle.us/support


changes use Correct Text, details in Working with Text.

Searching OCR Text
The text generated by the OCR operation can be searched like any other text. See Searching

Within A PDF.

Tips to Improve the OCR Results of Your Document:
The quality of the original document affects the quality of the OCR performance. Crisp,

clean originals with clear text will produce much better results than crumpled, faded

photocopies.

Place your original document on the scanner as straight as possible. If you have a scanned

page that is not straight, you can "deskew", or straighten, the image in PDFpenPro by

choosing Edit > Deskew and Adjust Image…

Increase the contrast of your scanned document so that the background is as white as

possible. You can adjust the contrast of the image by choosing Edit > Deskew and Adjust

Image…

Forcing OCR
PDFpenPro looks at the document and if it sees one image the size of a page, it assumes that the

document is a scan and automatically offers to perform OCR. In some cases, PDFpenPro may not

recognize a scanned document. Under the Edit menu, OCR Page will be grayed out and unavailable

to select.

1. Hold down the Command and Option keys together.

2. Choose Edit > OCR Page from the menu.

Viewing the OCR Text Layer
Once text has been recognized by the OCR process, it is placed on an invisible layer above the

image of text that you can see. When you copy text, the text is copied from this invisible OCR

text layer.

Text from the OCR text layer is a close, but not perfect, rendering of the bitmapped text. You will

need to proofread and edit the text that results from OCR. When you copy and paste the OCR

text, you may notice some inaccuracies which you can correct at that time.

View the OCR text layer:

1. From the View menu choose OCR layer. A layer of text will appear over your document,

showing the normally invisible OCR text.

Remove the OCR Layer
To completely remove the OCR layer from a document:

1. Open the Edit menu and choose Clear OCR Layer… (Command+Option+O).



At this point, you may redo OCR, or use the document as is. If you want to remove the OCR

from a document to redo it, you may Force OCR.

Editing the OCR Text Layer (PDFpenPro Only)
Make corrections to the OCR text layer.

1. From the View menu choose to view OCR info. A layer of text will appear over your

document, showing the normally invisible OCR text.

2. Select some text and a popup window will appear with options for editing the text one

word or line at a time.

Changes to the OCR text layer are not the same as changes made using the Correct Text tool

since changes to the OCR text layer are not made to the visible text of the document.

Also, like using the Correct Text tool, this is aimed at correcting typos and small errors, not

reformatting an entire document. For layout changes and major edits, export the document to

Word format, and make changes in a word processor.

Dictionaries and OCR
Medical and legal dictionaries are included in PDFpenPro’s OCR engine to improve the quality of

OCR output for scanned documents by recognizing words specific to the medical and legal

professions. This feature is built-in, so there is no need to turn on or adjust any setting. If you

choose to edit OCR text, misspelled words for selected text may be displayed with a red squiggly

underline.
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Help: Adding Pages
Adding a Blank Page

1. Choose Edit > Insert Blank Page (Command+Option+B).

2. A blank page will be inserted after the current page.

Adding a Page from Another PDF
1. Open both PDFs, the first PDF has the page you want to transfer, the second is the

destination PDF.

2. Show Thumbnail view in the Sidebar by clicking on the Sidebar button  in the toolbar

and selecting Thumbnails from the menu (View > Thumbnails).

3. Drag the thumbnail of the page you want to tansfer and drop it on the second PDF.

4. Drop the new page anywhere on the page currently on view and it will be inserted

before that current page.

Drop your new page in a specific location in the PDF by using the Thumbnail view

in the Sidebar. (See Sidebar). Hover between two thumbnails until you see a line

appear, then drop the page in.

Adding Multiple Pages
You can select multiple pages to add:

Select a range of thumbnails by selecting one thumbnail and then Shift-clicking on the

thumbnail at the end of the range of pages you want to add.

Select multiple thumbnails that are not in a sequential range by Commanding-click on the

thumbnails you want to add.

Select all the thumbnails in a PDF by selecting one thumbnail and choosing Edit > Select All

from the menu (Command+A).

Once selected, drag the pages from the Sidebar of one PDF to another, making sure that you drop

them between, before, or after the pages where you want them inserted.
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Help: Deleting Pages
Deleting a Page

1. Show Thumbnail view in the Sidebar by clicking on the Sidebar button  in the toolbar

and selecting Thumbnails from the menu (View > Thumbnails).

2. Find the thumbnail of the page you want to delete and select it.

3. Click the Delete button on your keyboard or choose Edit > Delete from the menu.

Deleting Multiple Pages
To select a range of thumbnails, select one thumbnail, then Shift-click on the thumbnail at

the end of the range of pages you want to delete.

To select multiple thumbnails that are not in a sequential range, Command-click on the

thumbnails you want to delete.

Note: Removing a page with a Table of Contents entry automatically removes the associated

entry from the Table of Contents.
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Help: Reordering Pages
Reorder a Page

1. Show Thumbnail view in the Sidebar by clicking on the Sidebar button  in the toolbar

and selecting Thumbnails from the menu (View > Thumbnails).

2. Find the thumbnail of the page you want to move.

3. Drag and drop the page in a new location among the thumbnails in the Sidebar. At the

location you want to drop the page, hover between two thumbnails until you see a blue

line indicating the drop destination, then drop the page in.

Reorder Multiple Pages
You can select multiple pages to move.

To select a range of thumbnails, select one thumbnail, then Shift-click on the thumbnail at

the end of the range of pages you want to move.

To select multiple thumbnails that are not in a sequential range, Command-click on the

thumbnails you want to move.

To select all the thumbnails in a PDF, select one thumbnail and choosing Edit > Select All

from the menu (Command+A).
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Help: Extracting Pages
Extract a Page

1. Show Thumbnail view in the Sidebar by clicking on the Sidebar button  in the toolbar

and selecting Thumbnails from the menu (View > Thumbnails).

2. Find the thumbnail of the page you want to extract and click on the thumbnail to select.

3. Choose File > New > "From Selection"

A new document with your selected page will create.

Extract Multiple Pages
Select multiple pages to extract and create a new document, or add to another open document.

To select a range of thumbnails, select one thumbnail, then Shift-click on the thumbnail at

the end of the range of pages you want to move.

To select multiple thumbnails that are not in a sequential range, Command-click on the

thumbnails you want to move.

To select all the thumbnails in a PDF, select one thumbnail and choose Edit > "Select All"

from the menu (Command+A).

Once multiple pages are selected, either choose File > New > "From Selection" to create a new

document with the selected pages, or drag the selected pages from the Sidebar of the original

document into the Sidebar of another document.

Tips on Extracting Pages
Selected pages in the original document will not automatically delete when extracted. If

you no longer want the pages in the original document, select the pages in the Sidebar and

tap delete on the keyboard to delete them from the document.

To expand the Sidebar view, hover over the divider between the Sidebar and main view

until you see a double arrow. Drag the divider to the right to see all the pages.

To split a PDF document into individual PDFs, locate the AppleScript icon  and

choose Script > "Split PDF."
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Help: Combine PDFs
Combining Two PDFs

1. Open the two PDF files that you want to combine.

2. Set the Sidebar to show Thumbnails in both PDFs. Show Thumbnail view in the Sidebar by

clicking on the Sidebar button  in the toolbar and selecting Thumbnails from the menu

(View > Thumbnails).

3. Select all the thumbnails in one of the PDFs by selecting one thumbnail and choosing Edit >

Select All (Command+A) from the menu.

4. Drag the thumbnails from the Sidebar of one PDF to the other. The pages will appear

wherever you drop them. If you want them added to the beginning of the PDF, drop them

in front of the pages already there. Likewise for the middle or end.

Tips on Combining PDFs
If you only want to combine selected pages from two PDFs, see "Adding Pages" to learn

how to select multiple pages at a time.

You can import one PDF into another by choosing File > Insert. The pages of the file you

choose are inserted after the current page.

You can also import one or more PDFs into another by dragging PDF files from the Finder,

Preview, and Microsoft® Word into the thumbnail view. The pages of the file you choose

are inserted at the insertion point.

If both documents have Tables of Contents, the entries will merge in the destination

document.

Combining Two or More PDFs Using AppleScript
PDFpenPro has a number of useful AppleScripts you can use to combine PDFs. Locate the

AppleScript menu  icon on the far right of the menu bar, after the Help.

Combine PDFs
1. Choose "Combine PDFs" from the AppleScript menu.

2. A window opens asking you to choose PDF files to combine. Find the files that you want

to combine and select them.

3. Click Choose.

4. PDFpenPro creates a new Untitled PDF with the pages from the files you selected, in the

order that they appear. Save the new PDF.

Note: The files must all be in the same folder to be combined using the Combine PDFs

AppleScript.

Merge Every Other
Merge two PDFs, interleaving the pages. This assumes you have two scanned documents, one being

a scan of odd numbered pages, the other a scan of even numbered pages. The resulting document

interleaves pages from each.

1. Start by opening the document with the odd numbered pages. Choose AppleScript menu >

Merge Every Other.

2. In the Choose a File window, select the PDF with even numbered pages. The result, one

PDF with page numbers intermixed into correct numerical order.
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Help: Cropping Pages and Documents
Selecting Part of a Page

1. Choose the Select Rectangle Tool  from the Editing bar (Command+4).

2. Click and drag over a portion of the document. This area can contain text or images.

Drag at the side or corner of the selection box to resize it.

The dimensions of the box are given along each side. Select which units are used in

Preferences > Editing > Measurement units. (Preferences).

Move the mouse inside the box and the cursor turns into a Hand move tool. Use

this to reposition the selection box on the page.

Once this area is selected, it can be copied and pasted to another page or to another PDF

document. It can also be used to crop the page or to create a new PDF document.

Cropping A Page

1. Choose the Select Rectangle Tool  from the Editing bar.

2. Click and drag the mouse to select a rectangular area of your PDF.

3. Choose Edit > Crop Page To Selection.

Crop every page in a document by holding down the Option key when in the Edit menu. The

option to Crop Page to Selection turns into Crop Document to Selection.

Creating a New PDF from a Selection

1. Choose the Select Rectangle Tool  from the Editing bar (Command+4).

2. Click and drag the mouse to select a rectangular area of your PDF.

3. Choose File > New > From Selection (Command+Shift+N).

Exiting a Crop Selection
Once you have a selection, but want to leave the selection without taking any action, choose one

of the other selection tools, like the Edit tool (Command+2).
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Help: Numbering Pages
Headers, Footers, and Page Numbers
Add header and footer text and page numbers to your document. Select from a variety of positioning

and formatting options. A preview displays the location of each on the page based on the currently

selected options. You cannot have header/footer text and page numbers in the same position. Apply

headers, footers, and page numbers all at once, or separately to allow for different formatting options

for each, such as fonts and page ranges.

Adding Page Numbers
1. From

the menu bar choose Edit > Headers, Footers, Page Numbers > Insert. The Header, Footer,

Page Number dialog opens.

2. From the Position menu, choose whether to put the page numbers at the top of the page in

the header, or at the bottom of the page in the footer.

3. Check the Page Numbering box to add page numbers. Otherwise, only a header or footer can

be applied.

4. Select from the following options:

Alignment: specifies the alignment of the inserted page numbers. Choose Left,

Center, Right, Inside or Outside.

Format: specifies the format of the inserted page numbers. Choose Numeral,

Alphabetical, Roman or Bates. (See below for more information regarding Bates

Numbering.)

Starting Page: specifies the starting page number that will be inserted on the PDF

document.

Include numbers on first page: specifies whether to insert the page number on

the document's first page.

Font: select a font from the Font menu.

Number Layout: display numbers in a “Page # of ##” layout. See Advanced

Options.

Custom Range: apply numbers to a custom page range. See Advanced Options.

5. Click Insert.

PDFpenPro will automatically insert a page number in sequence on every page of the PDF document,

using the specified options.

Bates Numbering
For easier identification and faster searching in large sets of files, you can specify Bates numbering as
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one of the available Format options.

 

 

1. Choose

Edit > Headers, Footers, Page Numbers > Insert. The Header, Footer, Page Number dialog

opens.

2. Choose Bates Numbering in the Format option. The dialog will expand to display the

following additional options:

Prefix: specifies the optional Bates numbering prefix.

Digits: specifies the number of digits to use in the Bates numbering sequence. Valid

values range from 3 to 8.

3. Choose other options, as described in the above section.

4. Click Insert.

PDFpenPro will automatically insert a page number in Bates numbering sequence on every page of the

PDF document, using the specified options.

Adding Headers and Footers
1. From

the menu bar choose Edit > Headers, Footers, Page Numbers > Insert. The Header, Footer,

Page Number dialog opens.

2. From the Position menu, choose whether add a header or a footer.

3. Uncheck the Page Numbering box if you do not wish to add page numbers also.

4. Select from the available header/footer options:

Text alignment: type your header/footer text into the Text area of the dialog.

Type into the Left, Center, or Right fields or any combination of the three to align

your header/footer to the area of the page. If one field is greyed out a page number is

in that spot.

Font: select a font for the header/footer. This will also apply to any page numbers.

Custom Range: apply the header/footer to a custom page range. See Advanced

Options.

Advanced Options
At the bottom of the dialog click the arrow next to Advanced Options to reveal more options:

 



 

Template: allows flexible page numbering layouts, including “Page # of ##” where macros &

[Page] and &[Pages] stand in for the “current page” and “total number of pages,” respectively.

Listed templates are displayed as follows:

“#” = &[Page]

“Page #” = Page &[Page]

“Page # of ##” = Page &[Page] of &[Pages]

To customize the layout of the page numbers, type some text in the Template field, then use

the # or ## buttons to add the macros for “current page” and “total pages.”

Insert from page: and To page: specify start and finish pages for headers, footers, or

page numbers, allowing for an optional custom page range.

Margin Positioning: specify units (e.g. points) from the margins for Left, Right, or Vertical.

PDFpenPro will automatically insert a page number in sequence in the specified custom page range of

the PDF document, using the specified options and template format.

Editing a Header, Footer or Page Number
Headers, footers, and page numbers cannot be edited in place. Instead, reapply it.

Removing a Header, Footer or Page Number
1. From the menu bar choose Edit > Headers, Footers, Page Numbers.

2. From the sub-menu:

Select Remove Page Header to remove a header or a page number at the top of the

page.

Select Remove Page Footer to remove a footer or a page number at the bottom of

the page.

Adding Line Numbers
Insert line numbers in a document, similar to those in a legal document.

1. Choose Edit > Insert Line Numbers to apply line numbers to the current page. Line numbers

will appear on the left side of the page on every line with text.

For multiple pages, shift-click and select multiple thumbnails in the sidebar before using the Insert Line

Numbers command. Command+A will select all the thumbnails.

Set the font in editing Preferences > Page numbers font:.
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Help: Reducing Document File Size

If your document contains many high-resolution images or annotations, you can reduce its file size

to send, share, store, or archive more easily. PDFpenPro includes several ways to reduce a

document’s file size. Depending on your document, you may use all or only a few of these options

for reducing the size of your PDF files.

Create Optimized PDF
The resolution of images and graphics increases a file’s size. Create Optimized PDF in PDFpenPro

allows for customized downsampling of images, decreasing the number of pixels to reduce the

overall file size. If your document benefits from optimization, PDFpenPro will create a new

optimized version of your PDF.

1. Choose File > Create

Optimized PDF.

2. Set options in the Optimize

Image window for: color,

grayscale, and monochrome

compression.

3. Specify settings for: 

Resample Reduces

file size by decreasing

image resolution. This

process decreases the

number of pixels in

images by converging

original pixels into

larger pixels.

Format Provides

three options: Leave as

is, Lossless (ZIP), Lossy

(JPEG). Lossless (ZIP)

is a better selection for

documents with

sizeable areas of flat

color and is known for

its ability to retain

original detail.

However, lossless may

not save as much disk space compared to other compression methods. Lossy

(JPEG) is better for compressing color images and photographs that include color

transitions and gradients. Compared to lossless, lossy compression can produce

much smaller files.

Quality Select from a range of levels (Lowest, Low, Medium, High, Highest). The

best method depends on the type of images in your specific document.

4. Select any additional options:

Remove third-party metadata Check this option removes background

metadata from objects and images for privacy purposes while providing the

additional benefit of reducing file size. Standard metadata such as title, author,

subject, keywords, time of creation—found in Document Information—will not be

removed in this particular process. Removed metadata includes thumbnail images,

image data, object data, objects that are images, such as XML, and more.

Optimize image only if it saves space Check this option if you want
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PDFpenPro to skip any images that may increase the file’s size during the

compression process.
5. Choose “Create” to create a new PDF with smaller file size.

While compression is in process, PDFpenPro will display a progress bar. This operation can take a

few seconds or much longer, depending on the size and contents of the particular document. If

successful, PDFpenPro will create a new untitled optimized version of your file along with dialog

will with the resulting file size and amount of space saved. If the currently selected optimization

settings will not save space, an “Optimization did not produce a small file” dialog will appear, and

PDFpenPro will not create a new optimized PDF.

Resample Image
Users have an option to manually reduce the file size of scanned documents through the Resample

Image option. See Scanning a Document. Resampling images typically reduces the size of an image

by changing the resolution and reducing color depth.

Generally, Edit > Resample Image allows you to resample a document down to 1-bit text,

grayscale, or JPEG compression, and to select the dpi you want. Either can be used to effectively

and considerably compress documents. Either compress a specific image, a page, or select the

option to "Resample Entire Document" to reduce image sizes document-wide.

Tip: There is a small trick to get resampling to work. Besides choosing a lower dpi, next to the

"Color JPEG compression" dropdown menu, there should be a percentage indicator—normally

choosing 50% lowers file size considerably while retaining good quality.

Quartz Filter
Under File > Save As, it is possible to specify a quartz filter for document compression. See Saving

and Compressing File Size. These can be customized in the ColorSync Utility application in the

macOS Utilities folder. It is possible to experiment with creating different Quartz filters to see if

they offer better results.

Tip: There are some cases where using the Quartz can increase file size, typically with larger

documents. In these cases, please contact support for further investigation.

Advanced PDF Compression
PDFpenPro includes several built-in compression methods throughout the application, including

resource compaction, such as colorspaces and fonts, to help you obtain smaller file sizes

automatically. Some of the improved areas include:

Scanning

Resample Image

Deskew & Adjust Image

Save/Save As workflow

Here are a few details on how they work in the background.

MRC compression
Mixed Raster Content compression (MRC) works best on mixed text and image PDFs and

can reduce files down to 2% of the original size. It works by separating images into multiple

layers and compressing each layer. The result is a lossless compressed document,

maintaining the same or higher quality of images and text as the original.

CCITT fax compression
International Coordinating Committee for Telephony and Telegraphy (CCITT) Group 4

compression is a lossless compression best for black and white or scanned 1-bit images.

Post OCR compression
All OCRed files come out smaller thanks to post OCR compression, which includes both

MRC and CCITT methods. Best when you need to scan a document in high resolution for

OCR accuracy, but would like to recover disk space after the OCR process is complete.
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Help: Printing
Page Setup
The first step of printing should be to visit File > Page Setup (Command+Shift+P) in case you need

any special settings, or to double check the settings that you have now. If you are printing to a non-

standard sized paper, or need to specify a special paper size, you can in File > Page Setup > Paper

size. You should also select the printer you are using in this window.

While PDFpenPro can handle documents with variable page sizes within the document, such pages

should be printed separately with the appropriate Page Setup for each.

Print Dialog
Once you are ready to print, go to File > Print (Command+P). This will bring up the Print Dialog.

There are extra settings in the expanded Print Dialog. View them by clicking Show Details in the

lower left corner of the dialog box. The last popup menu should be set to PDFpenPro for these

options to show.

Print Dialog settings:
 

Automatically reduce large pages to fit paper size 

Checked automatically.

Automatically adjust printing orientation for best fit 

Checked automatically.

Append annotations summary (See Print Notes and Comments) 

A final page, or set of pages, will be added to your document with a list of annotations

made to the document.

Print annotation summary only (See Print Notes and Comments) 

Print out a list of annotations, such as notes, comments, and highlighted text, without any

of the original document.

Print comments  (See Print Notes and Comments) 

Comment text boxes added to your document will be visible.

Print notes  (See Print Notes and

Comments) 

Any notes will be listed at the bottom of each

page, like footnotes. The page will reduce in size

to make room at the bottom, as indicated in the

images to the right.

Print imprints only (See Print Notes and

Comments) 

The original text of the document will not print.

Only the imprints you have added will print. This works well when you only want to print

out answer fields onto a pre-printed form. An imprint is anything you add to the

document, text boxes, comments, notes, shapes, and free form scribbles.

PDF 

Look in the lower left corner of the Print Dialog, click on the PDF button. From there you

can select Save as PDF… This will print your PDF to PDF instead of to paper, but with

similar properties. Just like a paper print, all your annotations (comments, images,

signatures, etc.) will be flattened on the document and uneditable.

Print Non-Continuous pages
To print only select pages, open the sidebar to Thumbnail view and Command-click on the pages
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you want to print. Choose File > Print.

Tiled Printing
PDFpenPro will not scale pages up so that one page will print tiled over several sheets.

Get Rid of PDFpenPro Watermark
If you are not a registered user, a watermark will be stamped on your saved document and prints.

Once you purchase and register you can get rid of that watermark.

1. Open a file that was saved with a watermark.

2. Resave that file. The watermark will disappear.

If you resave and that watermark does not go away, that likely means you did not save the PDF

(File > Save, File > Save As…), but printed it as a PDF (File > Print > PDF > Save as PDF…). This

acts the same as printing it to paper, and the watermark, along with any annotations, is permanent.

Locate the version of your PDF from before you printed, and it will not have a watermark.
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Help: iCloud
Open, save, and manage documents in iCloud and iCloud Drive. Items in your Library sync using

iCloud.

Manage your PDF documents using iCloud Drive
From within PDFpenPro access documents in iCloud Drive via the File > Open and File > Save

dialogs. You will see all the iCloud Drive folders just as you do in Finder.

Manage your PDF documents

Opening Documents
To open a document, choose File > Open. On the left of the Open File dialog is a list of sources,

including iCloud Drive and the PDFpenPro iCloud folder. Select a document and press Open.

Moving Documents to and from iCloud
To move documents to/from local storage to iCloud, open a document in PDFpenPro, click the

small arrow on the right of the document title, and pick a new location in the Where pop up

menu.

Integration with PDFpen for iPad & iPhone
If you have PDFpen for iPad & iPhone, you can set it to use iCloud to store and manage your

documents via the Settings item under the Tools icon. You can use PDFpenPro to manage the

PDFpen documents on iCloud from your Mac.

System Requirements
macOS 10.12 (Sierra) and later, and an Apple ID with an iCloud account.
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Help: AppleScript
PDFpenPro includes extensive AppleScript support so that it's possible to automate the PDF

manipulation process.

Example scripts are included with the application. Click on the AppleScript icon  in the menu

bar to see the included scripts.

The first time you click the AppleScript icon, select Populate Scripts Menu to grant permission to

copy the example scripts into the Application Scripts folder. Click on the AppleScript icon again to

see and try the scripts.

PDFpenPro scripts are stored in: [HOME]/Library/Application

Scripts/com.smileonmymac.PDFpenPro .

Combine PDFs
See Combine PDFs for more.

Cover Fax Header
Cover up the unwanted header of a fax. Choose the amount of space below the top of

the page that needs to be covered in increments of 72nds of an inch. Note that the

header is not erased, merely covered with an opaque white rectangle.

Export Form Data… 

Export to view the data generated from a filled out form. Data is exported in .csv

format, which can be changed by editing the AppleScript.

Imprint all Pages as First 

Copy an imprint made on the first page of a document to all pages. Imprints are objects

made with any markup to drawing tool. See Imprints for more.

Imprint all Pages with Image
Place an image on all pages of a document. Click this option and a window opens to let

you locate and select the image on your computer. To add a watermark see

Watermarks.

Imprint all Pages with Text
Place a selection of text in the center of each page of a document, E.g. Draft. To add a

watermark see Watermarks.

Merge Every Other 

Combine odd and even page numbered PDFs. See Combine PDFs for more.

Number Pages using Bates Numbering 

Add page numbers using bates numbering. See Numbering Pages for more.

Number Pages 

Add page numbers to your document. See Numbering Pages for more.

Remove All Imprints 

Remove all imprint additions that you have made to a PDF. See Imprints for more.

Reverse Pages 

Reverse the order of pages, so the last page is viewed first, and the first page is viewed

last.

Split PDF
Divide a PDF, making each page a separate document.

Open Scripts Folder
To add new script, quickly access the folder where scripts are stored.
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You may view the application AppleScript dictionary by dragging the PDFpenPro application onto

the Script Editor icon.

You may view the source of any script by holding the Option key and choosing the script from the

AppleScript menu.

If you create a script you'd like to share with other PDFpenPro customers, please let us know.

You're welcome to send such scripts to support.

Automator Workflows (macOS 10.8 and later)
You can also place Automator workflows in the scripts folder. When selected, the frontmost PDF

is the input for the Automator workflow. If you'd like the output to open in PDFpenPro, add a final

Open Finder Items action set to Open with: Default Application, if PDFpenPro is your default PDF

application, or set to Open with: PDFpenPro explicitly otherwise.

If you create a workflow you'd like to share with other PDFpenPro customers, let us know. Please

send such workflows to support.
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Help: Creating and Editing a Table of Contents
(PDFpenPro only)
You can view a Table of Contents in PDFpenPro, (See Sidebar for details). To create and edit a

Table of Contents, PDFpenPro is required.

More info on the difference between PDFpen and PDFpenPro

How to upgrade to PDFpenPro from PDFpen.

Creating a Table of Contents
1. Open the Table of Contents in the Sidebar by clicking the Sidebar button  and choosing

Table Of Contents from the menu. Or choose View > Table of Contents.

2. Go to the page that you want to add to the Table of Contents.

3. From that page, you can select a specific portion of text to be the title of that page in the

Table of Contents. Select that text now.

4. Click on the Cog button  at the bottom of the Sidebar and choose Add Entry.

Locate shortcuts for this in Edit > Table of Contents.

5. "Page X" will appear in the Table of Contents. You can click on the item to edit it. If you

selected text, that text will now appear as one of the headings in the Table of Contents.

Combining Tables of Contents
Combining documents with Tables of Contents will merge the entries, using the document names

as the top entries. Combine documents by dragging a file into the thumbnails sidebar of an open

document, dragging thumbnails from one document to another, or using the Combine PDFs script,

accessible in the menu bar's Scripts menu.

Fast Edit Access
Right-click, or Control-click, in the sidebar to access the context menu which contains all the same

options as the Cog menu. Editing options are also available from the Touch Bar on supported

Macs.

In addition to Add Entry, the Cog menu also provides the following means of adding new entries.

Add Child
Add a child to the currently selected Table of Contents entry. Combines Add Entry and

Demote Entry into a single action.

Add Aunt
Add an aunt, i.e. a sibling of the currently selected Table of Contents entry's parent.

Combines Add Entry and Promote Entry into a single action.

Editing Table of Contents Entries
Once you have added items to the Table of Contents, there are a number of ways you can edit the

entries: locate keyboard shortcuts for editing in Edit > Table of Contents, or Right-click / Control-

click on an entry to access editing options.

Shift-Click to select a range of page entries to perform batch edits on entries, such as demoting

and promoting.

Here are a few of the edit actions you can take on an entry:

Edit the Text of the Entry
Double-click on the entry to change the text.

Demote an Entry

Select an entry and click on Demote in the Cog menu . The entry will become a

subheading of the closest higher-level entry above in the list.
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Promote an Entry

Select an entry and click on Promote in the Cog menu . The entry will move up a

level from the section it is in.

Delete an Entry

Select an entry and click on Remove Entry in the Cog menu .

Copy Entries
Copy the text of an entry, or copy the entire Table of Contents as a bulleted list.

1. Click on an entry in the Sidebar. Press Command+A to select all the entries.

2. In the Edit menu choose Copy As Text. You can then paste the entries where you wish.
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Help: Converting HTML to PDF with PDFpenPro
More info on the difference between PDFpen and PDFpenPro

How to upgrade to PDFpenPro from PDFpen.

To convert an HTML file to a PDF document:

1. Choose File > New from HTML…

2. Locate the HTML file on your hard drive or enter the complete http:// web address of an HTML file in the search field.

3. Choose Create to finish.

4. A PDF document will be created containing your web pages.

There are several settings in the New from HTML… window.

URL:
Paste in the complete target http:// web address or HTML file location on your hard drive.

Select Index File…
Convert HTML files on your computer to PDF.

1. Locate the folder containing the HTML and image source files you would like to transfer to PDF. Then click Select Folder.

2. Next, select the specific HTML file which is the index of the HTML files to be converted. Click Select Index File.

Levels:
Choose how many pages deep to go into the website.

1 level = the current URL page.

2 levels = the current page and all linked pages.

3 levels = the current page, all linked pages, all linked pages on those pages.

etc…

Follow links to:
There are three options. Assuming you wanted to make a PDF of the URL http://www.apple.com/macbookair/index.html you would use the options as

described below.

Subtree: Most limiting. If you start with the above web site, /macbookair/ acts as the subtree, meaning all included HTML files will start:

http://www.apple.com/macbookair/

Server: If you start with the above web site then all included HTML files will start:

http://www.apple.com/

Any: Most encompassing. Will ignore Subtree and Server and collect any linked page, regardless of URL relationship.

Maximum number of pages:
Limit the number of pages collected.

Open Page Setup…
Open the Page Setup to choose the PDF Page size (e.g. US, A4).

Margins:
Set the amount of space between the text's edge and the page's edge.
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Help: Creating Forms with PDFpenPro
More info on the difference between PDFpen and PDFpenPro

How to upgrade to PDFpenPro from PDFpen.

With PDFpenPro, you can create an interactive fill-in PDF form with the ability to submit the data

via web or email. PDFpenPro can even automatically create form fields and checkboxes in a static

form. (One form per PDF document is supported.)

Automatically Add Form Fields and Checkboxes to Static PDF Forms
PDFpenPro can scan a static form and add interactive fields for you.

1. Open a PDF form with static fields. Go to Edit > Create Form Fields…

2. The Automatically Create Form Fields dialog box appears, click OK.

3. A progress bar appears while PDFpenPro detects the text fields and check boxes of the

form. A chime indicates completion.

You will notice that all of the fields are highlighted in gray to indicate their location. This is turned

on automatically when the fields are made active. You can turn this off by choosing View >

Highlight Form Fields.

Creating Forms
When creating a form you may want to design the layout in another application for the best layout,

then print that document to PDF, and use PDFpenPro to add the interactive form fields.

Adding Form Elements Manually

1. Open the Form Elements menu by clicking the Form Elements tab  in the editing bar.

2. Choose the form element you want to add.

3. Click in the PDF to add the element. Drag the corner handles of the selected element to

create the size and shape you want. For assistance in positioning your elements, go to

Inspector > Alignment. (See Inspector).

4. Choose Inspector > Form Element Properties to set the properties of each form element.

Save frequently-used form fields in the Library. The next time you want to use the form fields, just

drag it from the Library onto the page. (See Library).

Form Elements
To add any form element, click on the tool to activate it, then click on your document page to add

the element. Click and drag to set a custom size for the element.

Text Field The area of the form allowing unique data entry. When adding a text field,

you can click and drag to get the field size you want.

Checkbox Used for a one or more options, any or all of which can be selected. When

adding checkboxes, PDFpenPro automatically adds a text label next to the element that

can be selected separately and resized, moved or deleted. Choose a display option in Form

Element Properties.

Radio Button Used for a group of options where only one can be selected. When

adding radio buttons, PDFpenPro automatically adds a text label next to the element that

can be selected separately and resized, moved or deleted. Choose a display option in Form

Element Properties.

Choice Field Used to create a drop down menu of selectable options. Add and remove

options via Form Elements Properties (below).

List Field Used to create a group of selectable options. Add and remove options via the

http://smilesoftware.com/
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Form Element Properties (see below).

Signature Field Add an interactive signature field which aids in the signing of a form.

Click and drag to select the size and placement of the field. A “Sign Here” stamp will

appear in the upper right corner of the field. For details on how the field acts see Using an

interactive signature field.

Submit Button Used to add a button to your form to submit form data via email or

web. When adding the button, a dialog will open allowing you to enter a destination URL

or email address for the data to be sent to.

For more on submitting forms, see PDF Applications and Submitting Forms.

Testing Your Form and Editing Appearance

You will need to switch to the Select Text Tool  (Command+1) in order to try out your

form. Switch back to the Edit Tool (Arrow)  (Command+2) in order to edit the appearance of

elements you've placed in your form.

Form Element Properties
PDFpenPro lets you edit several properties of the form elements in the Form Element Properties

tab of Inspector. The contents of the window varies depending on which form element is selected.

To view, choose Window > Form Element Properties, or click on the Form tab  of the

Inspector panel if it is already open.

Name
Every form element has a

name to differentiate it

from the others. 

Generally you use a

different name for each

field. A group of radio

buttons, however, should

each have the same name

but a different Checked

Value. This allows them

to work together (i.e.

only one button in a

group can be selected)

and each yield a different

result.

Default Value (Text

Field)

Set the text a user sees

in the text field before

the form is filled out.

Once you set the Default

Value you will notice it

does not appear

immediately in the text

field. You need to make it visible by choosing Edit > Reset Form.

Tool Tip
Create labels that describe each form element. Tooltips are particularly useful for form

fields that need more clarification beyond the name of the field. To test, hover over the

form field to display the tooltip. VoiceOver uses tooltips (effectively accessibility tagging)

when describing form fields.

Checked Value (Radio Button, Checkbox, Submit Button)

This is the value yielded when the associated radio button or checkbox is checked.

Character Limit (Text Field)

Check this option to set the max number of characters that can be entered into a text

field.

Required
Check if you require this form field to be filled out by the user. The user will be notified



when they try to save the form which fields are required but not yet filled.

Size to fit (Text Field)

The text field can grow or shrink to fit the text that is entered.

Multi-line (Text Field)

The text field can contain more than one line of text.

Scroll text (Text Field)

The text field will scroll horizontally and/or vertically in a fixed size so that more than just

the visible text can be entered.

Check by default
Set a checkbox or a radio button to be checked before a user fills out the form. Once you

choose this option you will notice it does not appear immediately on the form. You need

to make it visible by choosing Edit > Reset Form.

Name and Value (Choice Field, List Field) 

When a list of options is available, each individual item requires a name, the value is

optional. The name will be used as the value if a value is not chosen.

Label, Submission Options (Submit Button)

Set the submit button title. Access the submission options. For more on form submissions,

see PDF Applications and Submitting Forms.

You can edit multiple properties at once by selecting multiple form fields at a time. Use the Shift or

Command keys with the Edit tool to select more than one item.

Editing the Tab Order
PDFpenPro lets you change the tab order of form elements added to a page. Select Arrange >

Show Tab Order to see the tab order within a page. Using the Arrange > Move options will move

the selected form elements back or forward within the tab order. Arrange > Reset Tab Order will

force the tab order of items in a page to reading order.

Editing Tab Order Using Sidebar

1. Click the Sidebar button  and choose Form Fields .

2. A list of your fields will appear in the sidebar, drag and drop to reorder. The tab order will

match the order of the elements in the list.

Sending PDFs for Electronic Signature (E-Signature)
To send documents for signatures with DocuSign® electronic signature (e-signature) service, see

Sign or Send with DocuSign®. When uploading a PDF with form fields to a DocuSign envelope or

template, the DocuSign system will recognize and convert the fields into comparable DocuSign

recipient fields. Form fields can be assigned and further customized to specific recipients in

DocuSign.
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Help: PDF Applications and Submitting Forms
PDF Applications for Submitting Forms
There are several PDF tools one can use to fill out and submit a form.

PDFpen and PDFpenPro support submitting forms in HTML, XFDF, and PDF

formats. They do not support submitting forms in FDF format. A user can download the

free demo of either application and use it to fill and submit a form.

Preview does not support submitting forms. Forms created in PDFpenPro will show an

introductory page explaining this and offering a download link for PDFpenPro.

Adobe Reader supports submitting forms in HTML, FDF, and XFDF formats.

Adobe Acrobat supports submitting forms in HTML, FDF, XFDF, and PDF formats.

Nuance Reader supports submitting forms in HTML and FDF formats. When XFDF is

specified, Nuance Reader will submit in FDF format.

Basic Form Data Collection and Processing
Once a user clicks the submit button on the form, the data entered into the fillable fields is

packaged in XFDF format and sent to the designated location, i.e. a URL or an email address. To

setup the submit button, see Creating PDF Forms. Please note that XFDF is the only available

option with the submit button.

When a user submits a form via email, you, the form creator, will receive an email with an XFDF

file containing the filled content of the form. View this data by appling it to the original form. Do

this by opening a blank copy of the form, then running the script: ”Process XFDF“. Download it

from here:

http://smilesoftware.com/downloads/Process_XFDF_1.0.zip

Why XFDF?
Of the available formats, XFDF is the least proprietary and the easiest to post-process. It would be

great if a simple comma-separated value (CSV) or tab-separated value (TSV) format were available,

but these are not part of the PDF specification and therefore cannot be offered.

Data Formats
XFDF (XML Forms Data Format) is very flexible because it's basically just the form

contents wrapped in XML. This makes it easy to parse with other tools.

FDF and PDF are used with forms which are submitted within the Adobe ecosystem.

Post-processing FDF files with anything other than Adobe products is difficult and not

recommended.

HTML is handy if one already has backend form processing scripts and wants to adapt

them to handle PDF forms. Otherwise, it is neither as regular nor as easy to post-process

as XFDF.

References:
XFDF Specification:

http://partners.adobe.com/public/developer/en/xml/xfdf_2.0.pdf

FDF Specification:

http://www.adobe.com/devnet/acrobat/pdfs/fdf_data_exchange.pdf
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Help: Portfolios
Gather a group of files together into a single unit. You can select a wide range of file types (PDF,

PNG, DOC, and more) to be part of a portfolio.

Open a Portfolio
Open a portfolio as you would any other PDF. See Opening and Creating PDF Files. It will open in

PDFpenPro to the portfolio window just like any other document.

Create a Portfolio Document
1. From the menu bar choose File > New > Portfolio Document.

2. In the new portfolio window, click the "+" button and choose Add Files. If you would like

your files in a folder, first create a folder by choosing New Folder. Then double-click on

the folder to open it, and choose the "+" button to add files to the folder.

You cannot drag and drop files from the main folder into a sub-folder, so be sure to create any

folders you want, then add files directly into those folders.

Navigation
Switch views from a sub-folder to the main folder using the dropdown menu at the top of the

window.

Preview a File
Preview the contents on a file by selecting it then clicking the Preview button

.

Remove a File
Remove a file from the portfolio by selecting it and clicking the "-" button.

Extract a File from the Porfolio
Save out a copy of a file by selecting it and clicking Extract As…

Open a File from a Portfolio
Double-click, or control-click, on a PDF file to open it in PDFpenPro, or click Open As New

Document. To open other types of files, extract them and then open them using an app which

supports that file type.

To open several PDFs at once, click and drag to select several, then choose Open As New

Document. Each document will open in a new window.

Save a Newly Created Portfolio
Choose File > Save from the menu bar to open the save dialog.
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Help: Saving and Exporting

Saving with Versions
PDFpenPro supports versioning. To restore your document to a previously saved version:

1. Choose File > Revert To…

2. From the menu which follows choose between:

Last Saved

Last Opened

Browse All Versions…

Saving with Encryption
For details see Passwords, Permissions, And Encryption.

Compress file size using a Quartz Filter
1. Choose File > Duplicate (Command+Shift+S) then in the new document choose File >

Save (Command+S). Or use File > Save As (Command+Option+Shift+S).

2. From the Quartz Filter pop-up menu, choose Reduce File Size.

Typically this reduces the size of your original file.

The other Quartz Filter settings can also recolor images. You can create your own Quartz Filters

to meet your needs in the ColorSync Utility application. Filters you create can then be chosen

from the Save dialog.

Note: For additional document compression options, see Reducing Document File Size.

Exporting in Microsoft® Word Format
PDFpenPro supports converting a PDF into a Word document.

1. Open the PDF you would like to convert and choose File > Export…

2. Select Word 2007 (DOCX) from the Export dialog.

For added accuracy, please select the language of your document in the “Language(s) in

document:” menu.

3. Click Export.

Depending on the size of the PDF this may take a moment. The dialog will change to show

a progress bar along with the amount of time elapsed since the conversion started, and the

estimated amount of time the conversion will take.

4. Once the conversion is finished a Save dialog appears. Choose a location on your hard

drive to save this new Word document.

5. Click Save to finish.

Open After Saving is checked by default. If you don't wish the Word file to open after you

save it, uncheck this.

Note: The older .doc Word format is not supported. Due to licensing limitations, Word export is

only available to registered users. To see examples or for more information, please visit

https://smilesoftware.com/PDFpen/wordexport.

Exporting to Microsoft® Excel, PowerPoint, and PDF/A Format
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(PDFpenPro Only)
Convert a PDF into Microsoft® Excel, Microsoft® PowerPoint, PDF Archive (PDF/A) .

1. Open the PDF you would like to convert and choose File > Export…

2. Select the desired type of document, Excel 2007 (XLSX), PowerPoint 2007 (PPTX), or

PDF/A from the Export dialog.

For added accuracy, please select the language of your document in the “Language(s) in

document:” menu.

3. Click Export.

Depending on the size of the PDF this may take a moment. The dialog will change to show

a progress bar along with the amount of time elapsed since the conversion started, and the

estimated amount of time the conversion will take.

4. Once the conversion is finished a Save dialog appears. Choose a location on your hard

drive to save this new document.

5. Click Save to finish.

Open After Saving is checked by default. If you don’t wish to open the file after you save it,

uncheck this.

Note: An Internet connection is required for PowerPoint and PDF/A export. Due to licensing

limitations, Microsoft® Excel, Microsoft® PowerPoint, PDF Archive (PDF/A) format export is only

available to registered users. To see examples or for more information, please visit

https://smilesoftware.com/PDFpen/wordexport.

Exporting In Various Formats
Exporting to Plain Text (.txt) or Formatted Text (.rtf)

1. Choose File > Export…

2. From the “Export to:” menu, select either “Plain Text (.txt)” or “Rich Text (.rtf).”

Note: Plain text means all formatting (font, color, image, sizing) will be stripped from the

document.

Export as TIFF, JPEG, PNG, Flattened PDF
1. Choose File > Export….

2. From the “Export to:” dialog that opens, choose a format, and select from the available

export options:

Color Mode:

Color (full color)

Grayscale (smaller in size)

1-bit (smallest possible size)

Resolution:

72 (Web) dpi

200 (Fax) dpi

300 dpi (print quality)

600 dpi (photo print quality)

Export each page as a separate TIFF file.

A Flattened PDF does not offer any export options. It takes all the annotations on the PDF, such as

a drawn signature, and flattens them so that they are no longer editable.

Saving to Evernote
Utilize the convenience of cloud information storage through Evernote. To save directly to

Evernote choose File > Save to Evernote...

Evernote is a versatile tool for capturing a wide variety of information and syncing that information

among a variety of platforms, including iPhone and iPad. Evernote Standard is free, and offers most

of the features you need to manage your notes and files. Evernote Premium extends the upload

limits, among other extras. You can sign up for a free Evernote account.
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Sharing Documents

Look in the upper right of the menu bar and click on the Share button  to send your

document to someone. Use Mail, Messages or AirDrop. You will see a list of your most recently

contacted for quick access.
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Help: Passwords and Permissions
There are two types of passwords a PDF document can have:

User Password:
Required to open and view the document. This password encrypts the document so that

the contents are only viewable by those with the password.

Owner Password (Permissions PDFpenPro only ):
Required to change document permissions, but not to view the document. The document

is visible to all, but saving, printing and/or copying may be restricted by the document

owner.

While the user password secures the content of the document from view, the owner password

secures what can be done with the content. A document may have both passwords.

Setting a User Password
1. Choose File > Duplicate (Command+Shift+S) then in the new document choose File >

Save (Command+S). Or use File > Save As (Command+Option+Shift+S).

2. At the bottom of the Save dialog select an Encryption option. We recommend Strong.

3. Enter a password in the Password field.

4. Re-enter the same password in the Verify field.

5. Click Save.

Whenever a password-protected PDF is opened, the user will be asked to enter the password you

specified. You can test this by closing and opening your document.

Encryption Levels
The encryption level of a document determines it’s security and which other PDF applications can

view it. There are three levels of encryption to choose from.

Weak: 40-bit RC-4 encryption level. Files with this encryption level can be viewed by

users of any PDF viewer.

Strong: 128-bit AES encryption. Files with this encryption level can be viewed by users of

PDFpen 4.2 and later, Adobe Reader 7 and later, and Preview in macOS 10.5 and later.

Strongest, least compatible: 256-bit AES encryption. Files with this encryption level

can be viewed by users of PDFpen 5.3 and later, Adobe Reader 9 and later, Preview in

macOS 10.7 and later.

As of version 6.2.1, PDFpen supports working with files using 256-bit AESr6 encryption created

with Adobe Acrobat X and later. PDFpen cannot encrypt new files with this encryption level, but it

can open and save files at this level. Users of Preview will not be able to view files at this

encryption level.

Setting Document Permissions

(PDFpenPro only)
Set an owner password in a PDF to control the document's permissions. Document permissions

settings specify whether certain actions are possible, such as printing or editing. These actions can

only be performed by someone with the owner password.

Note: Adobe Reader, Preview, and PDFpenPro do respect document permissions, but not all PDF

editing applications do. Document permissions can be helpful in preventing casual PDF users from

editing or other restricted activities, but they should not be relied on as foolproof security.

1. Open the Inspector window to the Document Permissions tab. (Window > Document

Permissions).

2. Click the Add button.

3. Enter your desired password in the Password field, and then enter the password again in
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the Verify field. Click OK to finish.

4. Select your permissions. The Presets popup has a list of common permissions settings,

explained below.

5. Choose File > Save to apply these settings.

The owner password is now required to set or change these permissions. Test this by closing and

opening your document.

Permissions Settings
Note: We recommend using the presets when possible since certain settings are mutually

exclusive.

Print
Allow a user to print the PDF.

Allow high-res printing (not recommended)
Allow a user to print to PDF via the Print Dialog. This will flatten the PDF, negating all

permissions settings. With this setting Off, that Print Dialog option will not appear.

Modify any content
Includes the options for Modify Pages, Fill forms, and Annotate documents.

Modify pages
Reorder, copy, delete pages.

Copy text and objects
Copy document content outside the document.

Fill forms
Allow a user to fill in form fields.

Annotate documents
Add comments, notes, highlights, markups.

Allow accessibility (recommended)
Allow accessibility utilities, such as VoiceOver, to have access to the text of the document.

The level of encryption is noted at the bottom of the window.

Permissions Encryption
The default encryption of document permissions is AES–128. You can change this by adding a user

password, details above. The permissions encryption will take on the same encryption level as the

user password.
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Help: Transitioning to PDFpenPro 12
Welcome to PDFpenPro 12! Here are a few new things you will see in this version.

We’re grateful to everyone who’s helped us with feedback over the years. Your contributions help

make 12 one of the best PDF editors available for Mac. Keep your comments coming!

What’s different from PDFpenPro 11?
From improved file sizes to DocuSign® integration for PDFpenPro users, 12 is all about portability,

collaboration, and customization. Here are the highlights:

Smaller files sizes
You’ve asked, so we’ve added several ways to reduce those file sizes.

Optimize PDF
Compress your PDF’s file size without compromising the quality of images using PDFpenPro’s new

PDF optimization feature. Open File > Create Optimized PDF... to control how much to resample

color, greyscale, and monochrome images.

Additionally, the “Optimize images only if it saves space” option enables PDFpenPro to skip any

images that may increase file size during the compression process. If your document benefits from

optimization, PDFpenPro will create a new optimized version of your PDF.

Advanced PDF Compression
We’ve integrated several different compression methods throughout PDFpenPro to help you get

smaller file sizes automatically. Some of the improved areas include:

Scanning

Resample Image, Deskew & Adjust Image

Save/Save As workflow

We’re pretty excited about the results. Just run one of your bigger documents through one of

these processes, save it, then compare the file sizes!

Here are a few details on how they work in the background.

MRC compression
Mixed Raster Content compression (MRC) works best on mixed text and image PDFs and

can reduce files down to 2% of the original size. It works by separating images into multiple

layers and compressing each layer. The result is a lossless compressed document,

maintaining the same or higher quality of images and text as the original.

CCITT fax compression
International Coordinating Committee for Telephony and Telegraphy (CCITT) Group 4

compression is a lossless compression best for black and white or scanned 1-bit images.

Post OCR compression
All OCRed files now come out smaller thanks to new post OCR compression. Best when

you need to scan a document in high resolution for OCR accuracy, but would like to

recover disk space after the OCR process is complete. For those of you who regularly

batch OCR, or archive your files, this feature is for you.

Remove third-party metadata
Found in File > Create Optimized… the option to “Remove third-party metadata” will delete

background metadata from objects and images for privacy purposes. It will also provide the

additional benefit of reducing file size. Most metadata such as title, author, subject, keywords, time

of creation—found in Document Information—are standard. However, metadata can also include

thumbnail images, image data, object data, objects that are images, such as XML, and more.
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Collaboration and customization
Callout tool
PDF files enable cross-platform collaboration through comments, notes, and other annotations.

Now, you can use the Callout tool  to edit and create new callouts—a type of text box

connected by a line and arrow—calling attention to a specific item or section of a page. Need to

annotate documents for use as exhibits, or create charts? This tool is for you.

Magnifier window
While you can always adjust the page zoom in PDFpenPro, this may not be enough. Some PDFs

include drawings, charts, or tables with impossibly small font or intricate details. By popular

request, you can now use the magnifier window. Choose Window > Magnifier and position your

cursor to examine small details on sections of your page, up to 2000% magnification.

Customized paper styles
Choose from a variety of paper styles for more effective note-taking, organization, and

customization. Available under the File > New... menu, unlock the versatility of colored and lined

paper.

Orientation options in the File > New menu
You’ve always been able to rotate pages, but have you ever wanted to select an orientation when

creating a brand new document? Under the File > New... menu, choose a preferred orientation for

your new document or page. Specify portrait or landscape from the start.

New welcome experience
Many of you asked for more “welcome” in the way PDFpenPro first launches the app. We’ve

incorporated your feedback. Start up PDFpenPro 12 for the first time, and we’ll walk you through

some of the most common tasks as well as offer places to get even more info.

DocuSign® support (PDFpenPro only)
Do you work with contracts or agreements? PDFpenPro users can directly send out documents

for signatures via DocuSign®, a leading trusted e-signature service for businesses. Accessing

DocuSign is as simple as choosing File > DocuSign > Log in to DocuSign. Quickly, easily, and

securely upload your documents for signature and send it to clients in just a few simple steps.

For a complete list of all the little tweaks and big additions see Detailed release notes.
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